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3 Menu Iltems

3.1 Edit
3.1.1 Edit Menu, Overview

The main menu item "Edit" contains the following components, depending on
which editor, dialog or wizard is active or when working in the Project Explor-
er:

e Undo, page 89

® Redo, page 89

®  Cut, page 90

®  Copy, page 90

® Paste, page 90

® Delete, page 91

® Rename, page 91

e  Select All, page 91

e  Find and Replace, page 91, (character strings)

®  Bookmarks, page 96, bookmarking functionality in text-based editors
. Insert file as text..., page 97,

®  Browse, page 97, information about object position and dependencies
® |nput assistance, page 98

. Declare variable, page 100,

® Advanced, page 102, expanded list of commands for working with text-
based editors

® "List components" function, page 103

If required, the menu structure can be reconfigured via the
IndraWorks » Tools » Customize » Commands dialog.

3.1.2 Undo

lcon: &7
Default shortcut: <Ctri>+<Z>
Menu: Edit » Undo.

The "Undo" command undoes the editing step most recently carried out in
the currently active editor.

Repeated execution of the "Undo" command undoes all of the actions carried
out since the editor window was opened, one by one. This applies to all ac-
tions in the function block editors.

Use "Redo" to restore the result of the editing step just undone.

3.1 .3 RedO lcon: ™

Default shortcut: <Ctrl>+<Y>
Menu: Edit » Redo.

The "Redo" command restores the result of the editing step that was just un-
done.
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undone, one by one.

Icon: ﬂ

Default shortcut: <Ctri>+<X>
Menu: Edit » Cut.

This command transfers the current selection (object, character string) to the
clipboard and removes it from the previous position in the Project Explorer or
editor. In the Project Explorer, this applies to the currently selected object.
Several items can be selected at once.

3.1.4 Cut

= Note that not all editors support this command and that its use is
limited in some editors.

The possibilities for selection differ depending on the editor:

In text editors, for example, the selection can consist of a character string or
a single character.

In graphical editors, for example, the selection can include one or more ele-
ments inside a selection frame.

To insert the contents of the clipboard use the "Paste" command.

To transfer a selection to the clipboard without removing it from its current po-
sition, use the Copy command.

To remove a selection without changing the clipboard contents, use the "De-

3.1.5 Copy lete" command.

Icon:

Default shortcut: <Ctrl>+<C>
Menu: Edit » Copy.

The description for the "Cut" command also applies to this command, except
that when copying, the selection is not removed from its current position.

To transfer a selection to the clipboard and remove it from its current position,
use the "Cut" command.

Icon: |EI

Default shortcut: <Ctri>+<V/>
Menu: Edit » Insert.

This command inserts the contents of the clipboard at the current cursor posi-
tion.

Not all editors support "Paste" and its use can be limited in others. Graphical
editors only support the "Paste" command if a correct construct is established
when the insertion is made.

In the Project Explorer, this command applies to the currently selected object.

3.1.6 Paste
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3.1.8

3.1.9

3.1.10

Delete

Rename

Select All
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Several items can be selected at once. Depending on the current position, a
dialog might open in which to select whether the object on the clipboard
should be inserted above or below the position.

To transfer a selection to the clipboard without removing it from its current po-
sition, use the "Copy" command.

To remove a selection without changing the clipboard contents, use the "De-
lete" command.

Icon: }":

Default shortcut: <Del>
Menu: Edit » Deleting.

This command deletes the selection from the editor or from the Project Ex-
plorer. The contents of the clipboard remain unchanged.

In the Project Explorer, this command applies to the currently selected object.
Several items can be selected at once.

The possibilities for selection are the same as for the "Cut" command.

To remove a selection from the editor or object tree and simultaneously
transfer it to the clipboard, use the "Cut" command.

Default shortcut: <F2>
Menu: Edit » Rename.

The command allows to "rename" an object. In addition to changing the
name of the object itself, the names of its dependent objects can also be
changed automatically.

Example:

Renaming an axis causes the names of the address constants stored in the
global variable list "MiIcVarGlobal" to be changed as well.

Default shortcut: <Ctri>+<A>
The command can be used in editors to select the entire contents at once.

Find and Replace
Overview of Find and Replace

The Find/Replace commands are located in the "Edit" category. They can be
used to search an entire project for a character string and to replace certain
character strings with other character strings.

By default, the commands are located in Edit » Find and Replace .
Commands:

®  Find, page 92

® Replace, page 95

®  Search down, page 95,

®  Search down (selection)95

®  Search up, page 96,

e  Search up (selection), page 96
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Find lcon: &4
Default shortcut: <Ctri>+<F>

Use this command to search the project for a specific character string. The
search is executed in all areas of the objects in the project that can be edited.

To open the dialog "Search", click in the main menu on Edit » Find and Re-
place » Find.

The "Find" command opens the "Find" dialog:

Find what: |PROGRAM ﬂ Find Mesxt
[ Makch case [~ Searchup Find Al
[ Makch whale ward [ Use regular expressions Replace ==
Search: Active editor ﬂ Close

All open editars
Entire project

Fig.3-1: "Find" dialog
In the "Find" dialog, enter the string to be found, where the search is to take
place and whether the positions found are to be displayed all at once or one
at a time. Switch to the "Replace" dialog at any time.

Find what.  In the "Find what" input field, enter the string to be found (search string). The

selection list associated with the El button provides all strings entered since
the programming system was started.

Search options  Select the desired search options:
e Match case
This search considers the case of the search string.
e Searchup

The search area entered moves upwards. To search in a downward di-
rection again, disable the "Search up" option.

e  Match whole word
Only strings that exactly match the character string entered are found.
e  Use regular expressions

Use the ﬂ button for support when entering regular expressions to
search for specific character strings. The most commonly used regular
expressions are supported and are sorted into the following submenus:

—  Special characters
- Repetitions

- Altematives

- Groups

—  Others

Searchin:  In the "Search in" selection list enter the objects that are to be searched for
and the character string to be found; see the following figure.
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Fined
Firidwhat:  [PROGRAM

[ ‘Mateh tace 1™ Searchiup
[ mstchwholeward [ Uss regular expressions

| -}‘;_\c_tlva_@dltor

8 Active editor
Al open editars
Entire project

Fig.3-2: "Find" dialog
Use thezl button to select one of the options from the list. The following can
be selected:

e  Active editor,

e  All open editors,

e  Entire project,

e  Only selection.

In addition, the D button can open the dialog for defining the search area
where the search can be specified, see the following figure.

‘Ohjerttypes: [ 'set-Accessor 7y
[[] 'set-Accessor O |
[C] Action i
|| Application G
[ Application (Safety) :_I

g .- EE. .m.--_
€ Seferrint 2y,

Fig.3-3: Dialog for enfering the search area

e  Entire project
Select the "Entire project" option if the search for the character string
should include the entire project.

e  Within the following objects

Select the "Within the following objects" option if the search is to be limi-
ted to the selected object types.

Proceed with the following steps:

1. Object types:In the Object types selection field, specify which ob-
ject types are to be included in the search for the character string
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list.

2. Name filter: Optionally, set a name filter for the objects to be
searched whereas placeholders "*" can be used. Example: If all
objects with "CAN" in their name are to be searched, enter "*CAN"
as filter here.

3. Scheme: You can save the current search configuration. Press
<Save...> and enter a name for the configuration in the "Save
Scheme" dialog.

All saved schemes are then contained in the selection list ( ¥ The
currently selected scheme can also be deleted again using the
<Remove> button).

save scheme x

Flease enteta name for the scherfe;

iErrorFIg

ok | Cancel J

Fig.3-4. "Save Scheme" dialog

e Al open editors: Select the "All open editors" option if only the open edi-
tors are to be searched for the desired character string.

o Active editor: Select the "Active editor" option if only the active editors
are to be searched for the desired character string. The active editor is
the editor for which the working area is displayed in the foreground.

e  Selection only: The "Selection only" option is ### being prepared ###
Use the "OK" button to confirm the settings.
Once all search options are defined, press the button...

Findnext  Click on the "Find Next" button to jump to the next position where the string
was found. The respective editors are opened and the string found is high-
lighted in the display.

Search all  In order to get a list of all positions found in the message window. The pro-
gress of the search process is shown in the status bar and can be canceled
early by means of the <Cancel> button displayed in the status bar if necessa-

ry.
After the search is complete, the following information is indicated regarding
each position:

®  Priority: Message icons.
Messages can include
Errorst¥

Warnings &- or

Just information »ﬂj
e  Description: Expression that contains the search string.
e  Origin: Path where the item searched for was found.

e Position: Position (e.g. line number) within the objects; "Decl" in brack-
ets stands for the declarations or "Impl" for the implementations of the
editor.
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The following is displayed below the list:

e  Total number of positions found

e  Number of objects in which the string was found

e  Total number of objects searched
Find all PROGRAM® [Entire project] I Q 0 Erors & 0Warnings @ 3 Messages

| ID | D escription | Element | Path | Path
PROGRAM PleProg PlcProg [Mle1: Logic: Application] Project: THIS_SUPER_S Line 1 [Cecl) PleProg [Mle1: Logic: Application] Project: THIS_SUPER_S

@ PROGRAM MationProg MationProg [Mlc1: Logic: Application] Project: THIS_SUPER_S | Line 1 [Decl) MationProg [Mic1: Lagic: Application] Project: THIS_SUPE.
@ Total found: 2 - Matching objects: 2 - Total objects searched: B Project: 1] Project:

Fig.3-5: Message window with positions found

To replace this string with another string, click on the Replace, page 95 but-
ton to open the "Replace" dialog.

Replace
&8
Icon: =&
Default shortcut: <Ctri>+<H>
The "Replace" command opens the "Replace" dialog, which is an extended
"Find" dialog; see the following figure.
Replace
Find whatt facet =l Find Next
Replace withy  fact ' Find Al
Bl T el
™ Matchwhoie pord. ¥ Lse regular sxprssions
Searchy[Entie project =]
1™ K maelfied objacks Gperi aftir Replace Al
Fig.3-6: "Replace” dialog
As in the "Find" dialog, select the options for finding the character string to be
replaced. In addition, enter the new character string in the "Replace with:"
field and then click on one of the "Replace" buttons; see the following table:
Button Function
The "Replace" button highlights and replaces the next string found
Replace . )
in the editor (step by step replacement).
Replace all The "Replace all" button replaces all of the strings found at once
P without displaying them in the respective editor(s).
Fig.3-7: "Replace” function commands
Search down lcon: 1,

Default shortcut: <F3>
Menu: Edit » Find and Replace » Search Down.

The "Search down" command can be used to move to the next position found
after using the "Find" or "Replace" commands to search for a specific charac-
ter string in the project.

Search down (Selection)

Default shortcut: <Ctrl>+<F3>
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Menu: Edit » Find and Replace *» Search Down (selection).

The "Search down (selection)" command can be used to move to the next
position found in the project for a character string that corresponds with the
string currently highlighted in the editor.

Icon: i

Default shortcut: <Shift>+<F3>
Menu: Edit » Find and Replace » Search Up.

The "Search Up" command can be used to move to the position previous to
the one found after using the "Find" or "Replace" commands to search for a
specific character string in the project.

Default shortcut: <Shift>+<Ctri>+<F3>
Menu: Edit > Find and Replace > Search Up (selection).

The "Search up (selection)" command can be used to move to the position
previous to the one found in the project for a character string that corre-
sponds with the string currently highlighted in the editor.

Icons:éjhﬁ%!

The menu item provides the bookmarking functionality for text editors. It can
be accessed in Edit » Bookmark or via the "Bookmarks" toolbar.

Bookmarks can be added to lines to facilitate navigation in long programs.

=

Bookmarks remain when closing the editor window.
If IndraWorks Engineering is closed, all bookmarks are removed.

The commands described below allow the setting of bookmarks and the navi-
gation with them.

Commands:

e  Switching Bookmarks, page 96,
. Next Bookmark, page 97,

®  Previous Bookmark, page 97

®  Deleting Bookmark, page 97

Icon: &
Menu: Edit » Bookmark » Set/Remove Bookmark

The command can set a bookmark in a text editor to set a bookmark in the
current line or remove an existing bookmark. A set bookmark is displayed as
cyan blue square in front of the line.
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11|13 ivar:l_err 1= iwar err +1
1z strvar_err := INT_T0O_3T]
13 bInc := FALIE:
14| END_IF
15
= lg|[] IF ivar_err > 3 THEN
17 ivar err := 0;
15 P OTR
Fig.3-8: Example of a bookmark in the ST editor

Next Bookmark

Icon: %
Menu: Edit » Bookmark » Next Bookmark

. Use the command to jump to the next bookmark (down) in the text editor.
Previous Bookmark

Icon: %
Menu: Edit » Bookmark » Previous Bookmark
Use the command to jump to the previous bookmark (up) in the text editor.

Icon: ﬁr
Menu: Edit » Bookmark » Delete bookmark
Use this command to delete all bookmarks in the active editor window.

3.1.12 Insert File as Text...

Use the "Insert file as text" command to insert a copy of the contents of a text
file into the currently active text editor. Open the "Insert file" dialog in order to
open a file.

To open the dialog "Insert file", click in the main menu on Edit > Insert file as
text... .

Find the desired file which has to be available in text format. The file contents
are then inserted at the current cursor position.

Deleting Bookmark

3.1.13  Browsing

Browsing, Overview Functions to navigate through the source text are available in the "Edit" cate-
gory. These are used to search the source text for information on the posi-
tions and dependencies (call tree) of a function block or a function currently
edited in an editor.

The functionalities for navigating source text are located in the main menu
Edit » Browse.

Commands:
®  Go to Definition, page 97,
¢ Display Cross References, page 98.

Go to Definition

_..
Icon:
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The "Go to definition" command can be used if the cursor is currently pointing
to an identifier in an editor window.

It is used to search the project for the position that contains the "definition" of
the respective variable or function block. Then, the function block, line or net-
work found is opened in the corresponding editor.

For example, if there are several instances of the selected object in the proj-
ect, the "Select online status " dialog opens to select whether the function
block should be opened in offline or online mode and - for function block in-
stances - whether an instance or the implementation should be displayed.

Altematively, the command is available in the context menu.

Example The following function block contains "fhinst", a function block definition,
"prog_y", a program call, and "fbinst.out", a function block call.

Example "Go To Definition”

VAR
fbinst:fbl;
ivar:INT;

END_VAR

prog_yQ;
ivar:=prog_y.y;
resl:=fbinst.out;

Cursor locations after using the "Go to definition” command

®  Place the cursor on "prog_y" and the command opens the "prog_y" pro-
gram in its editor.

° Place the cursor on "fbinst" and the command sets the focus to the dec-
laration window to the line "fbinst:fb1;"

®  Place the cursor on "out" and the command opens the "fb1" function
block in its editor.

Displaying Cross References

lcon: =

The "Display cross references" command displays the cross reference list
currently shown in the cross reference list window in the message box. To
open the dialog "Display cross references"”, click in the main menu on Edit
» Browse » Display Cross References. Altematively, "Display Cross Refer-
ences" is available in the context menu.

= Cross references in the cross reference list can also be automati-
cally updated.

An automatic update of the cross reference list can be activated
in the main menu via Tools » Options » IndraLogic 2G » Smart
coding » Automatically update cross references when changing
selection (see also "Cross reference list", page 107).

3.1.14  Input Assistance...

Icon: E
Default shortcut: <F2>
Menu: Edit » Input Assistance...
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The "Input assistance..." command, which opens the input assistance dialog,

is only available if the cursor is currently in a programming language editor
window.

The dialog provides all programming elements that can be inserted at the
current cursor position.

Alternatively, the command is available in the context menu.

oy

# {) rIL_FieldbucTypes -
Keywiords # 1) PIL_Netdioad

#

+

# () RIL_Profibusor 2
1) RIL_Profinetia o o
1) FIL_Profinetibevice. < v
€} PIL_Lfities. -~ wiitres, y:
} Standard stsagised 202 00(mstem)
0 Bistable Function Blacks

£ Ao 2o

# 170 Wisrrlianeni i< =
Ll o | >

=
FUNCTION_BLOCK CTUD j

o EQOOL WVAR_INPUT feount Up
O [BOGL VAR_INFUT [Count Dowr

RESET |BOOL WaR_INFUT |R959t Caurter t kull

hane han ki mno b nad starvalia =l v
Fig.3-9: "Input assistance” dialog: Declaration of an instance (without inserting
an argument)
PicF jonMict: Logic:. an] | *
PROGRTM PlcProg ]
= 2 VIR
3] beoDunmy:BOGL :
4 Cl: CTUD;
S EHD VAR |
« _ I
1 (*Thia 12 & placaholder. Please replaca ths plecakolder with your oun logiz, #)is]
2| boDumwy:=hofunny AHD boDumny:

e I
TnCorfig_Glohals Cancel [
IV Insart with ~ o [¥ Show docutmenitation
|
C1: CTUD;
(vAR)
= 4
Fig.3-10: "Input assistance” dialog: Implementation of an instance (with insert-
ing an argument)
The elements are sorted according to category. For the "Variables" category,

additionally set a filter for the variable type, like "Local variables", "Global var-
iables", "Constants", etc.
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Filter: |Canstants ﬂ

Mone

Local variables
Global variables
Inputs

Cutputs
Mappings
Parameter

Fig.3-11: "Fifter” selection window

Insert with arguments  If the "Insert with arguments" option is selected, elements that have argu-
ments, e.g. functions, are inserted with their arguments at the cursor position.

Implementation, Inserting with Arguments, C1. CTUD;
c1(

Structured view  If the "Structured view" option is selected, the elements are arranged in a free
structure based on subject and supplemented by icons.

If it is not activated, the elements are listed one after the other in alphabetical
order. The function block to which each belongs is also listed (e.g.
"GVL1.gvar1").

Show documentation  [f the "Show documentation" option is selected, the dialog is expanded to in-
clude the "Documentation” field. Here a help text is shown for the currently
highlighted element. This help text is automatically generated from a com-
ment that was entered when the element was created.

3.1.15 Declare Variable...

Default shortcut: <Shift>+<F2>

The command opens the "Declare variable" dialog, which supports the Decla-
ration of a variable, page 503,.

To do this, the cursor has to be positioned in a line of the programming sec-
tion of the editor that contains a variable that has not yet been declared or a
variable that has already been declared has to be highlighted.

= If the dialog is to be opened automatically as soon as a line that
contains a variable not yet declared is exited, the "Auto Declare"
function has to be selected in the options for smart code editing.
More information on "Auto Declare" or "Smart code editing" is lo-
cated in "Options, Smart Coding", page205, "Settings".

To open the "Declare variable" dialog, enter the variable name and click in
the main menu on Edit » Declare Variables... or press <Shift>+<F2>.
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[~ PERSISTENT =

oK I Cancel |

Fig.3-12: Dialog for variable declaration

A few fields in the dialog are automatically filled with default values, but these
can be edited: Name, Data type, Object

Visibility  In the "Visibility" selection list, "VAR" is the default entry for "local variables".
Alternatively, another validity range can be set in the selection list.

Name The default entry in the "Name" field is the name of the variable that has not
yet been declared as it was entered in the editor.

Datatype The default entry in the "Data type" selection list is "INT" if this variable is the
first one to be declared in the editor line.

However, if there is already a declared variable in the line, the data type for

this variable is listed, here "BOOL". To change this setting, use the E] but-
ton to access input assistance which provides all data types, see Input assis-
tance..., page 98.

Object  The default entry in the "Object" selection list is the name of the Project Ob-
ject, page 28 that is currently edited. To enter a different object, in which the
variable is to be declared, select one from the selection list. If a global varia-
ble list should be declared, it contains for example (visibility: VAR_GLOBAL)
all available global variable lists of the project.

Initial value  The "Initial value" field is empty by default. A valid value, which corresponds
to the data type of the variable and which is used to initialize the variable, can
be entered here. If the field is left empty, it is initialized with the default value.
The E] button opening the "Input assistance" dialog.

Address The "Address" field is empty by default. In the "Address" field, an IEC ad-
dress can be directly assigned to the variable (AT Declaration, page 512).

Automatically created declaration line

plus AT %I1X1.0: BOOL;

Flags  No flags are enabled by default. "CONSTANT", "RETAIN" or "PERSISTENT"
can be selected. Define whether the variable is a constant or a "remanent
variable", page 519, by selecting the corresponding "flags". The correspond-
ing attribute keyword is then inserted into the declaration after the keyword
defined in the "Visibility" field, e.g. "VAR CONSTANT".
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The "Comment" field is empty by default. Enter a text to be added to the dec-
laration as comment.

Breaks can be inserted with the shortcut <Ctri>+<Enter>.

The comment is then displayed in the declaration editor in the line above the
variable declaration.

Click on the "OK" button to close the "Declare variable" dialog. The variable
declaration appears in the declaration editor according to the IEC syntax.

There are additional commands for editing text in the project under "Edit".
By default, these commands are located in Edit » Advanced .
Commands:

e Goto..., page 102

®  Switch to upper case, page 102

®  Switch to lower case, page 103

e  Corresponding bracket, page 103

®  Highlight up to corresponding bracket, page 103

Default shortcut: <Ctrl>+<G>
Menu: Edit » Advanced » Go To...

Jump to a specific line within the active text editor using the command. The
command opens the "Go To Line" dialog to enter the desired line number
(jump target).

EETTEE

Line nurmber:

I, I Zancel

Fig.3-13: Dialog — Go fo line

Then close the dialog with the "OK" button. The cursor is placed at the begin-
ning of the corresponding line.

Default shortcut: <Ctrl>+<Shift>+<U>
Menu: Edit » Advanced > Switch to upper case

Use the command to display the currently highlighted text area in upper case
letters.

See also Switch to lower case, page 103.
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Switch to Lower Case

Corresponding Bracket

Menu ltems
Default shortcut: <Ctri>+<U>

Menu: Edit » Advanced *» Switch to lower case

Use the command to display the currently highlighted text area in lower case
letters.

See also Switch to upper case, page 102.

Menu: Edit » Advanced > Corresponding bracket

When the cursor is positioned at a bracket, the command can be used to
jump to the next related opening or closing bracket. This applies to brackets
within program lines and to "parenthesis enclosures", page212 that extend
across several lines.

Highlight up to Corresponding Bracket

Menu: Edit » Advanced » Highlight up to corresponding bracket

When the cursor is positioned at a bracket, the command is used to highlight
all of the code lines up to the corresponding closing or opening bracket. The
highlighted area can extend upward or downward. This applies to brackets
within program lines and to "parenthesis"”, page 212 across several lines.

3.1.17  "List Components" Function

Entering text is supported in the context of the IEC 61131-3 standard.

The IEC 61131-3-text editor also provides a type of "Intellisense" functionality
that can be enabled or disabled using the dialog in IndraWorks » Tools » Op-
tions *» IndraLogic 2G » Smart coding.

"List components" makes it easier to enter valid identifiers:

e |[fonly apoint"." is entered in a position where a global identifier can be
entered, a selection list of all available global variables appears. A varia-
ble can be selected and inserted after the period.

PROGRAM PlcProg
ViR
boDunnwy : BOOL:
fhinst: POU_SFC:
EHD VAR

Ton e L M

1| res:= .h

ZPAKIS_97

=R ARIS_O5

=R ARIS_09
@ hxisData
#[b_glabrear
@ b_persvar
4 BaseDevicedetup

fgh BaseTypelnformation
$ BIT_SL_FLAG_BIACTIVE
& BIT_SL_FLAG_BIDPY1_DATA_TYPES -

1

Fig.3-14: "List components” provides global variables (starting with 'b’)

° If a period is entered after a function block instance or structure variable,
a selection list provides all of the input and output variables of the func-
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Menu ltems tion block or all structure components. With a double-click or <Enter>,
insert the variable selected in this list after the period.

PROGRAM PlcProg

VAR
holDunwy : BOOL;
structwar: StructType;

. |

1 result:= structwar.

P

oo |

o divar
@ var

Fig.3-15: "List components” provides structure components
1 PROGRAM PlcProg
= £ VAR
3 bolunwy : BOOL:
4 thinst: FOU_3FC:

1 res: fhinst.
W ]
[F4METH
i out

HapProP

|58 Step_active

Fig.3-16: "List components” provides function block variables (compo-
nents)
e |f any character string is entered and <Ctrl>+<space bar> pressed, a se-
lection list of all available POUs and global variables appears.

The first element in this list that begins with the previously entered char-
acter string is automatically selected and can be inserted in the editor
with a double-click or by using the <Enter> key.

L PROGRAN PloProg
m < ViR
3 boDunmy @ BOOL ;
4 fhinst: FOU_SFC:
g tEatir ) i
EIFTRE 14]
© REAL
¢ REFERENCE
& RETAIN
() RIL_CommanTypos
{} RIL_FieldbusTypes
{} RIL Inline
{} RIL_Net¥load
{} RIL_ProfibusDP_02
{} RIL_Liiities

SR

Fig.3-17: "List components” provides list selection (starting with r))

3.2 View

3.2.1 View, General Information

The menu item "View" allows the windows and toolbars within IndraWorks
Engineering to be activated and deactivated.
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®  Project Explorer, main window to the left of the workspace Menu ltems

e  Device library, main window to the right of the workspace
®  Other Windows

—  OQutput

- Messages, page 105

—  Search results

—  Tools, page 106

—  Cross reference list, page 107

—  Element properties..., page 108
® Toolbars, (IndraLogic selection), page 109

—  Bookmarks, page 109

- IndraLogic, page 110, important commands for menu items "Cre-
ate" and "Debug"

®  Object properties in the Project Explorer, page 238.

If required, the menu structure can be changed using the dialog in
IndraWorks > Tools » Customize.

3.2.2 View - Other Windows

Messages

Menu: View » Other Windows » Messages

This command opens a window in which messages with regard to the project
are displayed.

[ 1 Eror | 1 Waring [[5) 5 Messages |
3)' — Buid siated Applicabor: [ICC_Caniiol 0 Appiication -— FProject 0
.:!;' Piecempiation: Code leer ' hat kenen Effelt. 1zt diss beabsichtigt? WA [Di_f;;_'fmﬂfulfm : Logic: Application] Projsct: J_.:"r'aiac:H_.‘_,’- | Line &; Calurmn 1 (Impl]
A Code Yest;" hat kenen Effekt |5t des beabsichtioh? WAIT [DEC_Conteol 01 Lomic: Appheation] Froject: Projeet13 | Line & Colurmn Impl)
Identifiet Yeet’ Aot defined WAIT [DEC_Contol 01 Logic: Application] Piojent: Project13 | Line 8 Colurme T (Il
‘&) Comple compiete ~ 1 encrs, 1 warmings Pioject 0
) Build complete 1 enors, 1 watnings - o download possible! Pigiect. o
1| | i
=] Oukpuk o Messages
Fig.3-18: Window: Messages, example after "Generate code”
Messages can include

e  Errorsty

e  Warnings PN or

° Information @

Messages are moreover categorized by component or functionality.

Messages regarding project syntax checks e.g. belong to the 'Precompile’
category; messages for compiling the project to the 'Compile' category (e.g.
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Menu ltems compilation errors, code size). Messages of the "Import", "Library Manager",
etc. categories are possible as well.

A filter for the desired message category can be setin the selection list at the
top of the message window (refer to the preceding figure) except for the Pre-
compile messages which are always displayed in the area below the actual
message table.

The messages in the selected category are output in table form and include
the following information:

®  Description (message text)
®  Project (project name)
e  Object (name of the associated project object)

e  Position (position in the object that triggered the message, e.g. line
number, network number, etc.).

If display of a certain message type is to be hidden or shown, use the buttons
in the upper right-hand corner of the window. Errors, "amings, Information,
Messages. The buttons also show the currently available number of messag-
es of the type.

Switch between the messages in the message window or jump from the cur-
rently selected message to the respective position in the object. For this pur-
pose, the 'Next message', 'Previous message' and 'Go to source text position'
commands are available.

Switch between the messages in the message window or jump from the cur-
rently selected message to the respective position in the object.

To do this, use these commands:
®  "Next message" and
®  "Previous message"

Double-click on a message entry in the table to move to the source text posi-
tion.

The task list can also be sorted according to a variety of criteria using the
"Sort by" command (context menu).

Choose from the following variants:
e "Time sequence"

®  "Priority"

e  "Description"

e "Origin" and

e  "Position"

Double-click on a message entry in the table or click on the precompile mes-
sage underlined in blue to move to the source text position.

Tools

Menu: View » Other Windows > ToolBox

This command opens a window with "tools" ("Toolbox") for the currently ac-
tive editor.

By default, this ToolBox is available for graphical editors or for the visualiza-
tion editor. It contains graphical programming elements that can be dragged
into the editor window using "drag&drop".
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Cross Reference List

Examples: Menu ltems

®  ToolBox for CFC editor, page 311
®  ToolBox for FBD/LD/IL editor, page 355
e  Toolbox for the Visualization editor, page 446.

This command opens a window in which the cross references for a specific
project variable are listed. Cross references include the positions in the proj-
ect where the variable is used.

" PlcProg|[Controt: Legic: Application] | x
I PROGRAM PloProg -
= . VIR
2 R1:RERL;
4 Sinus:REMNL ;
] Cosinus:BEAL;
)

st Ex: ST Example; -
4 {sf

& St Ex
ADD ST Example
Bl — rl sinusf—————————— Sinus
Ainus — + cosimisi— Cosinas

P Cross Beletence List

Marns; sinus: . A Sleles | S5

prill |Vizsriatte | Arcess | 'i'ﬁw | Sciipe | Address | Location |
FLCPROG Sinus Deklarsfion  AEAL  Lokal Line 4 [Bre<i]
PLCPROG Sinus: Lesen REAL  Lokal Metwork 1./ Operand S’ (Impl)
PLCPROG Sinus. Schieben  AEAL  Lokal Metwork 1/ Operand Sinus' (imgl)
PLCPAOG  snus Lesen FEAL  Lokal Metwork 1/ Operand ‘st_Ex’ (lmgd]
ST _EXAMPLE  snus Deklaration: RESL  Lakal Line & [Decl)
ST_ERAMPLE  sinue: Schieiben  HEAL  Lokal Line 1, Colomn 1 [mgl)

4| | |

(& Cross Refersnce List | Search Resuls
Fig.3-19: Example of a cross reference list

If all cross references within the entire project are to be listed: Jog the varia-
ble identifier manually or copy it from the editor window in to the Name field
by means of copy&paste and confirm by means of the <Enter> key or click on

the S button

If only the cross references within the same POU are to be listed: Mark either
the variable identifier in an editor window and drag it into the cross reference
window using the mouse or activate the Automatically update cross referen-
ces when changing selection, page 205 option and place the mouse cursor
in the identifier name in the editor window or select it. In this case, the identifi-
er is automatically applied to the Name field and the cross references are lis-
ted below.

An automatic update of the cross reference list can be activated in Tools
» Options » IndraLogic 2G » Smart coding .

If a valid identifier is entered, the use positions found are displayed in table
form with the following information about the variable:

POU Name of the function block in which the variable is used.

Variable Variable name
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Access Use of the variable at the given position: Declaration/read/write/call

Type Data type

Range Validity range: global/local

Address |[EC address, if defined

Position Position of the variable used within the editor (e.g. line number, net-
work number)

Comment Declaration comment for the variable

Fig.3-20: Cross reference list, fable header explanation

The list can be sorted alphabetically by column. By clicking on the column ti-
tle, switch the sorting arrangement between ascending and descending or-
der.

Double-clicking a line in the cross reference list opens the respective POU
and selects the position identified. This corresponds with the use of the

irbutton (Show position) if an entry in the list is selected.

Use # (Show previous position, shortcut: <Shift> + <F4>) to jump to the pre-
vious entry in the list.

Use ® (Show next position, shortcut: <F4>) to jump to the next enfry in the
list.

—+
Use (Go to definition, shortcut: <F2>) to jump to the position where the
respective variable is declared. To do this, the corresponding declaration edi-
tor opens and the variable is highlighted there.

The = button corresponds to the command Display cross references, page
98, which outputs a display of the current cross reference list in the message
window.

This can be useful if the current list is to be kept available even though the
automatic update is active and the list in the cross reference window can
change.

View - Element Properties, General Information

Icon:

Menu: View » Other Windows » Element properties

When this command is used, the main window "Properties" opens to the right
of the workspace.

If an appropriate object is highlighted in the workspace, its properties appear
in this window.

®  Element properties of sequential function chart objects, page 108
® Element properties of visualization elements, page 109
Using the command again closes this window.

Element Properties - Sequential Function Chart Object (SFC)

Icon:

Menu: View » Other Windows »> Element properties

This command opens the Properties window for the currently selected SFC
element.
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Menu ltems

Element properties such as name, comment, step times and associated ac-
tions are displayed in a subdivided table.

These can be edited in the 'Value' column:

Go to input mode by clicking the mouse and for steps place or remove a
checkmark in the checkbox to enable or disable the "Initial step" property.

See also the detailed information for the individual
¢  Element properties, page 404.

Element Properties - Visualization Element

Icon:
Menu: View » Other Windows »> Element properties

This command opens the Properties window for the currently selected visuali-
zation element.

The element properties are displayed in a table, sorted in groups. Click on
the plus or minus sign in front of the group name to display or hide the related
parameters.

Which properties can be configured depends on the visualization element.

A description of the individual parameters is located in the visualization edi-
tor, page 451,.

3.2.3 View - Toolbars

View - Toolbars, General Information

Bookmark, Overview

The IndraLogic PLC programming system provides the following toolbars that
are activated if editors associated with the programming system support it
and are active:

e  Bookmarks, page 96, bookmarking functionality in text-based editors

® IndralLogic, page 110, frequently used functionality of the menu items
Create and Debug.

Toolbars can be changed based on user-defined needs in
Q Tools » Customize .

The IndraLogic PLC programming system uses the following toolbars in con-
nection with the comparison of PLC objects:

®  Toolbar in the Comparison dialog, page 110.
®  Toolbar in the Comparison results dialog, page 111.

Icons:éjhh%!

The "bookmarks" toolbar provides bookmarking functionality for text editors. It
can be activated using View » Toolbars....

Bookmarks can be added to lines to facilitate navigation in long programs.

= Bookmarks remain when closing the editor window.
If IndraWorks Engineering is closed, all bookmarks are removed.

The commands described below allow the setting of bookmarks and the navi-
gation with them.
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Commands:

& Switching Bookmarks, page 96,
'Hr Next Bookmark, page 97,

% Previous Bookmark, page 97
% Deleting Bookmark, page 97

Icons:

08 @) ) mi(=c=cz-2 3| i

The "IndraLogic" toolbar contains frequently used commands for the menu
items Create and Debug.

for the application that is currently active.

% , Debug » Login, page 127; this command connects the program-
ming system, i.e. the active application with the control, thus establish-
ing the online mode.

q , Debug » Logout, page 128; this command ends the connection
between the development system and the control, causing a retum to
offline mode.

», Debug > Start, page 133; this command starts the application on
the control.

B Debug » Stop, page 133; this command stops the application on
the control.

EE, Debug » Procedure Step, page 142; this command carries out a
sequence of defined steps in the program in online mode.

%= Debug » Stop, page 133; this command carries out a single step
in the program in online mode.

t=, Debug » Execute to Return , page 143; this command starts the
processing of a program loop up to the return in online mode.

+=, Debug » Execute to Cursor, page 143; this command starts the
processing of program lines up to the cursor in online mode.

$, Debug » Determine Next Instruction , page 143; this command
specifies the instruction that is to be processed next.

g-, Debug » Display Next Instruction , page 143, this command shows
the instruction that is to be processed next.

The toolbar in the upper part of the dialog serves the navigation and provides
the following functions for comparison/merger:



RODAMIENTOS VIGO, S.A.

DOK-IWORKS-IL2GPRO*V12-AP01-EN-P

RODAVISS, 8.A. www.rodavigo.net +34 986 2388118

Servicio de Att. al Cliente

Bosch Rexroth AG 111/697

Rexroth IndraWorks 12VRS Indralogic 2G PLC Programming System

Menu ltems

Symbol

Description

Show previous element; Clicking this symbol navigates to the previous
element in the history of the already displayed elements.

v

Show next element: Clicking this symbol navigates to the next element
in the history of the already displayed elements.

L

Select next difference: Clicking this symbol selects the next difference.

=

Select previous difference: Clicking this symbol selects the previous
difference.

3

Preselect for the merger: Clicking this symbol preselects the selected
line for the merger.

Note: If no merger is possible for the selected line, no preselection can
be made.

X|

Reset preselection for merger: Clicking this symbol no longer prese-
lects the selected line for the merger.

A

Start merger: Clicking this symbol carries out the merger for all prese-
lected lines.

Fig.3-21:
Comparison Results, Toolbar

Toolbar

The toolbar in the upper part of the "Comparison results" dialog serves as fil-
ter and provides the following functions:

Symbol

Description

Show all elements: Clicking this symbol shows all differing and comply-
ing elements.

Show only differing elements: Clicking this symbol shows only the dif-
fering elements.

Show only complying elements: Clicking this symbol shows only the
complying elements.

3.3 Project Fg.5-22:

Toolbar

3.3.1 Archiving and Restoring

Archiving IndralLogic Projects

A detailed description of how to archive projects is located in the IndraWorks
help under Archiving Projects.

When archiving Indralogic projects, a check determines which libraries and
device descriptions are required for the project.

These are saved locally or on the FTP server in the archive.

Restoring IndralLogic Projects

A detailed description of how to restore projects is located in the IndraWorks
help under Restoring Projects.
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When restoring IndraLogic projects, the libraries and device descriptions re-
quired for the project to be restored are determined from the archive.

If these files are not in the Library Repository..., page 185, or in the device
database, the respective repository is supplemented from the archive when
the project is opened for the first time after restoration.

Displaying PLC Objects of an External IndraWorks Project

Icon:

Menu: Project » Display PLC objects of an external IndralLogic project

The command allows to open an external project and to copy PLC compo-
nents from its content.

Show PLC ehjects of an external Indral_ ogic project... |

Fig.3-23: Dialog: Selecting the source
Only the "IndraWorks" and "IndraLogic" project types are permitted.

With the "IndraWorks" project type, the standard dialog for selection of an

IndraWorks project opens after clicking on .

Dpen Proje E3

irt | (L] Einene Dateien [ (& I A i
Bk | jEigene Dokuments
| SiBlugtooth-Exchange-Ordner | 3Eigenes Google Gadgets
[etkion T ERC_Contral |=Eigane Maps
. B CrnpErrors (M Eigene Musik:
’ @Erosscnmlﬂ |'_|j:|E|gene-P05t
(Bipcc Base [=)Eigene Guery
Eiene Daisen | Y ol O] | EMIF
5000 _pase 2 ) Erste Schiitte FlesPrafile
EDEC_C{H\&DI_H‘EI:_F&H&: Ercte Schritte Maotlon
| Eince_Project {jErsteSchritte: Y11
| ED0c_Profect Fiethernet
1’ I ZZ:Z::Z:Z::Z:ZZﬂ

Proisct riae

"E‘*“'tjﬁ“;;f"ﬁf [Erte Scrite Motien

Directon:
IC:\Dokumente und EinstellungentusernametEigens D ateien

Q. I Zancel

P

Fig.3-24: Dialog: Selecting the IndraWorks project
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With the "IndralLogic" project type, you have to navigate to the desired

IndraLogic project after operation of
tion » IndralLogic * IndralLogic.project.

-l eg. First steps Mo-

B E

2 O oEs

Blzgkiam

4

Eigena Datsien

wr
“-\

Aroekspiatz

.
._.

I_I;wdrangic.nmiacL :J [ Open

I | Iridvalogic project files [ project]

Fig.3-25: Dialog: Selecting the Indralogic project
For both project types, a dialog appears to select the objects to be opened:
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4 Dhie-:l:s in External Indralogic Project - Indralogic

= Dt, nn:lraLu:u;uu:
DE' Project Setfmgs
= O] pec_contral
B D.FJH”I' Liidic
¥ F' DQ -':'-IJI'JI' =Hn
Fl UservarGlobal
16 Micvarciobat
| Library Manager
-5 MotionProg
[ E'g] MationProg_FLP
= E[I_ FlcProg
| i j'\u'rllLu_llx
= CJ&h Taskcanfiy
sk PleTask
O:& MotionTask:
0O crboard 1 o
O] sercos I Master
O trbne_1_o
O ] miche_verwendet
O3] Profibus_DP_Master

Select All | Select None |

QpeEn | Zancel |

Fig.3-26: Dialog: PLC object selection

Objects that can be selected (i.e. displayed) have black font, all others are
shown in gray font.

Using the "Select All" or "Select None" button, the user can mark all objects
for opening or remove their marking.

Clicking the button in front of a selectable object with the mouse marks indi-
vidual objects for opening.

If the user presses the "Open" button, the selected objects are opened for
read access. The user can now e.g. mark text passages in these objects and
copy them to objects of the open project.

The "External:" entry in the title of the document window shows the user that
the opened object comes from an external project.



DOK-IWORKS-IL2GPRO*V12-AP01-EN-P Bosch Rexroth AG 115/697
Rexroth IndraWorks 12VRS Indralogic 2G PLC Programming System

3.3.3 Data Transfer

Data Transfer, Overview
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¢ Estemn: UsetyarGiohal Extemn : MotionProg FUP |
:|  |prOSREM HoticnProg FUP
VIR

4

HoveVelVAl: HC MoveVelocity:
e MoweVelVil: BOOL:

VoomVal: BERL := Z0C:

in MoveVelVil: BO(L:
atc_MoweVe1lVil: BDOL:;

ca MowveWelVAl: BOOL:

er MoveWelVAl: BOOL:

ID MoweVelVAl: ERROR CODE:
11 Tdent MoveVelWAl: ERROR_STRUCT:
b i StopVal: HC Stop;

£3 ex ScopWAl: BOOL:

& W0 0 =1 thoA

HoveVelVial
MC MoveVelocity
ex_MoveVelVAl Execute InVelocity
WoomWAL Velocity Aotive - ac_Mowe¥elVal
20 Acceleration Commandiborted [—ca MowveWelWV4l
20 Deceleration Error [-er_MoveWelVAl

Fig.3-27: Opened external PLC object

IndraWorks provides a way to export complete projects and then to import
them again.

These projects contain components associated with the related system.

An export is performed from the respective object where the menu items "Ex-
port" and "Import" can be called in its context menu.

See also Exporting and importing project data, Rexroth IndraWorks 12VRS,
Engineering, DOK-IWORKS-ENGINEE*V 12-APxx-EN-P.

Indralogic itself provides a way to import IndraLogic projects created using
different platforms. Blocks, data types, visualizations and resources (global
variables, variable configuration, trace recording, control configuration, task
configuration, etc.) can be imported.

In order for projects to be imported, the following prerequisites have to be
met:

1. IndraWorks Version 8 or later
2. Open IndralLogic 2G project
3. IndraLogic 2G libraries

4. Device description files

The "Application" node context menu can be used to import existing
IndraLogic 1.x projects (both stand-alone projects and projects embedded in
IndraWorks) and IndraLogic 2G projects into IndraLogic 2G projects.

The following figure clarifies the relationships.
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Indralogic 1.x | IndraLogic 2G

o) ©)

® ® @
IndraWorks 07

Indralogic 1.x

Indralogic 1.x
( *.pro file)

Indralogic 2G
( *.project file)

O Indralogic 1.x projects embedded in IndraWorks (Version 7) are auto-
matically converted and then imported.

@ Indralogic 1.x projects embedded in IndraWorks (Version 8) are auto-
matically converted and then imported.

® IndraLogic 2G projects embedded in IndraWorks (Version 8) are im-
ported. In this case the project is not converted, since both file types
are identical.

®@® Stand-alone Indralogic 2G project files (*.project files) are imported.

® Stand-alone Indralogic 1.x project files (*.pro files) are automatically
converted and then imported.

Fig.3-28: Schematic representation of various imports

Importing IndraLogic 1.x Projects

Importing projects

To import an IndraLogic 1.x project, highlight the "Application node" in the
Project Explorer and select "Data Import..." from the context menu.

Alteratively, also import projects using the main menu Application » Data
Import... .

ISy

Note that you can have several applications in one IndraWorks
project. The data transfer applies only to the highlighted "Applica-
tion" nodes.

&m Project Explorer
B (] DOC_Base
iy Beninal maduls foldey
- el DCC_Corirol 01
El ........ Ejﬂ L‘Dgiu

o O HEE
['g Dnl_:uciérd'_ll:l L] .

o @ |n|ir'1.|5-.-'_|E| [|n|i1"1E='|_ -
vt ProfibusdM (Profit™=

St fckive Application

Fig.3-29:
The "Data Import..." dialog appears.

Importing Indral ogic projects
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Y
Project type
’7(3' Indratwéorks € Indralogic [ho conversion of the 10 configuration)
Froject:
] I Cancel |
Fig.3-30: Selecting project type and project path

Under "Project type" select the type of your source project.
e  IndraWorks:

In this case, an IndraLogic project (*.project) is embedded in an
IndraWorks project.

e Indralogic (IO configuration is not converted)

In this case, a stand-alone IndralLogic project file (*.pro or .project) is the
source project.

I Note that the control configuration is not imported for stand-alone
IndralLogic 1.x projects (*.pro).

Use the _I button to open the "Open Project" dialog and move to the proj-
ect to be imported.

2x
Suchenin; | () Bgsne Datsen zl OF =@

|5 tncraloge. 1.x_Projekt=_Importersn
| S Indral ogic 2.x_Projekte_Importeren

.C:‘-Mq.mi& wund Bnstellungen woembaum ' Bgens Dateien

Fig.3-31: File selection
Confirm your selection with "Open".
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Menu ltems = Before the import takes place, the project is recompiled. Compila-
tion errors might occur (e.g. if a library is missing), which can be
ignored in terms of the project import.

The download for the project starts. In a later step, device descriptions can
be installed to be able to ignore the following or similar error messages with

llN 0"_
ool ogic L to 2.4 Convester| S|
9 ) Ettorwhie bsdingthe PLC configurstionl
"2 Besciphin e o ol RA010107.g ot ftee
Change configuration directory?. :
T
Fig.3-32: Error message that might appear while the PLC configuration is load-

ing
The download includes a search for libraries required for the project. If the re-
quired libraries are not found, the following or a similar dialog appears.

Indralogic 1.xto 2.x Convertes ﬁ{

\':) <annak find 10.0F 13 libraries. Change lbrary diectory?

[ ] wen |

Fig.3-33: Dialog for libraries that are nof found

To enter the library path for the respective library, click "Yes". The "Options"
dialog opens automatically in which the paths for the requested libraries can
be entered.

Library path  Enter the correct path in the "Options" dialog.

oprons

Catagory
Load & Save (=
User Information: = ;
Edior Libranes: | ALIBS
Desklop = il fil I
Calors E fles: I'\
Diractories Configuration files: I_\[;DNHG\
Build Wisualization files:
Passwoids !
Source download .
Symbol configuration - Target
Edalabase-connectinn Libraries: |E:\Proglamme\Hekrolh\lndraWarks\IndraLonic\Tarnsts\lndraLonic_L#U_
acros

Configuration files: IE:\F’roglamme\F\ exrothindraWworkshlndral ogichT argetssindralogic_L40_

e I
General

Libraries: IC:\W\NDDWS\system32\
Compile files: IC:\W\NDDWS\system32\
Upload files: IC:\W\NDDWS\systemBZ\

Configuration files: |C:\W’\ NDOWS aystem32WPLCCOMNFY

EETETEET

“Wisualization files: I

Fig.3-34. Specifying library paths
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In the "Project" and "General" areas, in the "Libraries" selection field, se-
lect the directories that IndralLogic should search and use. The entries in
the "Project" area are saved with the project and those in the "General "
area apply to all projects.

The "Target" area includes a listing of the directories for libraries and
configuration files that are set in the target system, e.g. by input into the
target file. These fields cannot be edited.

Use "OK" to confirm your entries.

Converting library references  If there are libraries included in the project that do not yet have conversion
assignment saved in the "Library options", page 222,, the "Library Reference
Conversion" dialog appears for defining how these references are to be con-
verted:

Library Reference Conversion x|

The original profect raferences the following librany:
Standard.LIB (C:\Dokumentz und Finstellungen\x@arbaum\Figene Dateien | Indr
Thizs lbrary reference must be replaced by a reference Lo & [ibrary In the new file format.

‘What do you wantto do?—
% Convert and install the library a5 well,

™ Usethe followina lbrary that has already besninstailed:

aVWEE | Youmost selsct a- ibraty oy diodng e Broeese . Dofion

{~ Ignore the library. The reference will not appear in the converted project.

¥ Remember this mapping for all future occurrences of that library reference.

oK I Cancel |

Fig.3-35: "Library Reference Conversion” dialog
The following options are possible:

Convert and install the library.

If this option is selected, the integrated library is converted to the new
format and remains referenced within the project. It is automatically in-
stalled in the library repository in the "Other" category and remains
used. If the project information required for an installation (title, version)
does not come with the library, you are requested to enter this informa-
tion in the "Enter project information" dialog.

Use the following library that has already been installed.

Select this option if a library that has already been installed is to be used
for this reference. Use the "Browse" button to open the "Select Library"
dialog. Select the desired version of one of the installed libraries here.

This corresponds with the configuration of the version handling in the
"Library Properties" dialog (see "Library manager properties", page
230).

" means that the latest version of the library available in the system is

always used in the project. The list of available libraries is structured as
described for the "Library repository dialog", page 185,.

It can be sorted according to company and category.

Poligono Indutrial O Rebullén s/n. 36416 - Mos - Espafia - rodavigo@rodavigo.com
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e Ignore the library. The reference does not appear in the converted proj-
ect.

If this option is selected, the library reference is removed and the library
is no longer included in the converted project.

e Remember this mapping for all future occurrences of that library refer-
ence.

If this option is selected, the settings made in this dialog are also used
for future project conversions as soon as the respective library is refer-
enced.

For standard libraries, an assignment to the new libraries is already
specified.

Select the desired option and confirm with "OK".

In the "Enter project information" dialog, the imported library is uniquely iden-
tified. Fill in the "Title", "Version" and "Company" fields here.

Enter Product information

The tolowing information 14 required to idertity the lisrary:

Tl | My _Library

version: | 1.0

Company.  {Bosch Rewroth AG

Fig.3-36: Enter profect information (product information)
Title Specify the desired name for the library.
Version Input a unique version of the library.

Company Input the company name.

Use "OK" to confirm your entries.

In the "Current project object as import target." window, please select the ob-
jects to be imported.
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% Please Select the-Objects to Be Imported: - Indralogic

Currert project obiect 25 import target:
{00 Praject/DCC ConbroliLogic/Application

Pl=acs select the objects to be imparted:

——
1

ll—!'f:
il "!|E :.

‘_-'!

LiservarGliobsl
= ﬁl Library Manager
= 5] PicProg
¥ @ Micvarciobal

3 Symibol conf
== 5& Task Configuration
i~ _j I\‘J.D'rmPrl:\g
= HL TR 10 _Controfies L
[l ™ Proﬁbus DP _Masker_1
1 Sercos_III_Master
LTI B Project Settings

Mark Objacts Reguived for mport fo Target

ogect... Select All Select Mone |

Fig.3-37: Selecting the objects fo be imporfed
e Use the "Select All" button to highlight and import all of the objects.

e Use the "Select None" button to deselect objects that have been high-
lighted.

= For stand-alone IndraLogic 1.x projects (*.pro), the I/O configura-
tion is not imported into the target system.

= If you select objects that already exist in the target project before
the import, a selection dialog prompts whether to overwrite these
objects; see "Overwriting objects", page 121.

Overwriting objects  Objects that already exist in the target project can be overwritten by placing a

checkmark in the following selection dialog.

Indral ogic

One or several objects to add already exist. Please select those objects
which you want to be overwritten,

[w] Fle_Main[DCC_Cortral _01: Logic: Application]

all | Nongl Ok, I Cancel |

Fig.3-38: Overwriting objects
e  Use the "All" button to highlight all of the objects available in the dialog.
These objects are overwritten in the target project.

e Use the "None" button if you do not wish to overwrite any of the objects
in this selection dialog.

Click on "OK" to complete the object import. The imported objects are added
to the project. Finally, a message appears that indicates that the objects have
been imported.

Poligono Indutrial O Rebullén s/n. 36416 - Mos - Espafia - rodavigo@rodavigo.com
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Importing IndralLogic 2G Projects

Importing projects  To import an Indralogic 2G project, highlight the "Application" node in the
Project Explorer and select "Data Import..." from the context menu.

&m Project plurer
........ i Geriral moduls folder
- el DCC_Cantrol

=[] Login

e
.......... [ Dnbaard 0 (0 Sat &ctive pplication
.......... @ |n|h'g=_|c_|[|ﬂ|he=| " ke Troi

---------- Cam Prafibus/M (Profit™
oMy PROFINET IO

Fig.3-39: Importing Indral ogic projects
The "Data Import..." dialog appears.

Data Import... l =] g3 |

£ i coreion ok e 1 oo

r |

Fig.3-40: Selection dialog: Project import...

Under "Project type" select the type of your source project.

e  [ndraWorks:
In this case, an IndralLogic project is embedded in an IndraWorks proj-
ect (*.project).

e IndraLogic (IO configuration is not converted)

In this case, a stand-alone IndraLogic project file (*.pro or .project) is the
source project.

Use the _I button to open the "Open Project" dialog and move to the proj-
ect to be imported.
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|3 Indral ogic. 2.x_Projekte. Immorteren
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jects to be imported.

In the "Current project object as import target." window, please select the ob-

= Please Select the Objects bo Be Im;mlll'iE: Indral.ogic

LJ“‘IEI

I_ Arsl g
E- - IrcraMetiorM|pl
: B on
=i I‘a Appilicstion
¥ @ Us=rvarGiohal
¥ @ Library Manager
¥ =] PicProg
= @ Micvardiobal
09 sormbel corfigurstion

=¥ (38 Task Configuration
¥ =] motionProg
: R PROFINET 15 Controlles _L
-] B Profibus_DP_Masker_1

I'ﬁ Sercos_IIT_Master

g* Project Setkings

Mark Dbfacts Required For fmport fa Targef
Ohiace.. .

Select Al I

Select fone |

Fig.3-41:
Select objects
Fig.3-42:
[ ]
[ ]

Selecting the objects fo be imported

To start the import, click "OK".

Use the "Select All" button to highlight and import all of the objects
Use the "Select None" button to deselect objects that have been high-
lighted.
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= If you select objects that already exist in the target project before
the import, a selection dialog prompts whether to overwrite these
objects; see "Overwriting objects", page 124.
Overwriting objects  Objects that already exist in the target project can be overwritten by placing a
checkmark in the following selection dialog.
Cmiz or ssveral objects to add already sxdsh. Flease select those objscts
e yoll want b be owerwritten.
&l Pic Main[DCC_Control_01: Logic: Application)
ol | rone | o | concel |
Fig.3-43: Overwriting objects
e  Use the "All" button to highlight all of the objects available in the dialog.
These objects are overwritten in the target project.
e Use the "None" button if you do not wish to overwrite any of the objects
in this selection dialog.
To complete the import, click "OK". The imported objects are added to the
project, which is confirmed by a dialog.
3.4 Create
3.4.1 Create, Overview
The "Create" menu item provides functionalities to build a program, i.e. for
compiling an application program.
The "Create" commands are used for code generation and for syntactic
checks in all objects or in modified objects in the active application. Offline
code generation is possible in order to be able to check for compilation errors
before the code is loaded to the device.
The results are output in the message box, message category: Compilation
The "Clean" commands are used to delete the compilation information from
the target system that was saved during the most recent download and dur-
ing code generation. This affects Online Change, page 80, for example.
If required, the menu structure can be reconfigured via the
IndraWorks > Tools » Customize » Commands dialog.
Commands:
®  Compile, page 124,
®  Recompile, page 125,
®  Generate code, page 125
® Clean, page 125
3.4.2 Compile ® Clean all, page 125

Default shortcut: <Shift>+<F11>
Menu: Create » Compilation

Poligono Indutrial O Rebullén s/n. 36416 - Mos - Espafia - rodavigo@rodavigo.com



ROBAVIES, S.A.

RODAMIENTOS VIGO, S.A.

www.rodavigo.net +34 986 288118

Servicio de Att. al Cliente

DOK-IWORKS-IL2GPRO*V12-AP01-EN-P Bosch Rexroth AG 125/697
Rexroth IndraWorks 12VRS Indralogic 2G PLC Programming System

3.4.3

3.4.4

3.4.5

3.4.6

Recompile

Menu ltems
This command starts the compilation for the currently active application. This
means that all objects for this application are subject to a syntactic check.

= Note that no code is generated as it is the case when logging into
the target system or downloading the application!

The compilation is carried out automatically before every login with changed
program.

After the syntactic check is complete, error messages or warnings might be
displayed within the message window in the "Compile" category.

If the number of errors/warnings exceeds 500, all other messages are skip-
ped and a special message provides information about the situation.

Commands of the Message window, page 105, category are available in or-
der to navigate between the messages and between messages and source
code.

If the program has not been modified since the most recent error-free compi-
lation, it is not recompiled and the message "The application is current" is
output in the message window.

However, if the syntactic check should nevertheless be repeated, use the Re-
compile, page 125 command.

Menu: Create » Recompile.

The command starts the compilation for the currently active application again,
even if it was recently compiled without errors.

Generate Code

Clean

Clean All

Menu: Create » Generate Code
Generate code for test purposes with this command.

As with the login, compilation code is generated with the application in the
control, but the code is not loaded into the control. In this way, the code can
still be checked for compilation errors and corrected before it is used in online
operation.

Menu: Create » Clean

The command deletes the compilation information for the currently active ap-
plication. This information was created and saved during the most recent
download, page 132, of the application to the target system.

After the cleaning is complete, an online change, page 80, is no longer possi-
ble for the respective application.

First, the program has to be completely reloaded to the control.

Menu: Create » Clean All
The command deletes the compilation information for all applications,

After cleaning is complete, an online change, page 80, is no longer possible
for the respective applications.

First, the program has to be completely reloaded to the control.
See also Clean, page 125.
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3.5 Debug
3.5.1 Debugging, Overview

These commands influence the application program on the control in online
operation.

By default they are available in the main menu "Debug".

If required, the menu structure can be reconfigured via the
IndraWorks » Tools » Customize » Commands dialog.

For security reasons, when calling the commands that are marked with an
asterisk * below, users are always requested to confirm the selection.

An additional request for confirmation for the commands marked with two as-
terisks ** appears if the option Secure online operation, page 239, is enabled
in the communication settings for the respective device.

A CAUTION The extraordinary modification of variable val-

ues in an application running on the control
might lead to unwanted behavior of the con-
trolled system.

Depending on the controlled system, damage
at the system and workpieces might result or
the health and life of persons might be at risk.

Evaluate possible risks before writing or forcing variable values and take cor-
responding precautions.

A CAUTION The online change modifies the running appli-

cation program and causes a restart.

Depending on the controlled system, damage
at the system and workpieces might result or
the health and life of persons might be at risk.

Ensure that the new application code still results in the desired behavior of
the controlled system.

The commands.

® |login, page 127

® Logout, page 128

®  Generate boot application, page 129
. Logout current online user, page 129,,
e  Edit object (offline), page 130,

° Load, page 132, *

®  Online Change, page 133, *

e  Start, page 133, **,

®  Stop, page 133, **

e  Single cycle, page 134, **

e  Multiple download..., page 134**

. Reset warm, page 135%,

° Reset cold, page 135*,

®  Reset origin, page 136*,
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3.5.2

Login

e  Breakpoints, page 136, Menu ltems

® New breakpoint..., page 138

®  Toggle breakpoint, page 140

®  Breakpoint positions, page 138

e  (Call stack, page 141

®  Monitoring, page 141

®  Procedure step, page 142

®  Single step, page 142

®  Execute to return, page 143

e  Execute to cursor, page 143

¢  Determine next instruction, page 143

e Display next instruction, page 143

e  Write values for all online applications, page 144, **

®  Force values on all online applications, prepare value, page 145, **,
®  Cancel forcing for all value on all online applications, page 147**
®  Add all forces to monitoring window, page 148,

®  Sequence control, page 148,

® Display mode, page 151, **

Icon: ;

Default shortcut: <Alt> + <F8>

This command connects the programming system, i.e. the "active applica-
tion", page 66, with the target system (control or simulated device), creating
the online mode. To achieve this, the communication settings, page67, for
the device have to be configured correctly.

If the "Login" command is called from the online mode, the currently active
application is concerned.

If the command is called from the context menu if an application is selected in
the Project Explorer, login is carried out with this selected application even if
it is not set as "active application”.

The following situations are possible in case of login with the currently active
application (without errors, communication settings correct):

e  The application is not available on the conftrol yet: Confirmation of the
download (Load, page 132) is requested. A dialog with the following
text appears: "<Application name> application does not exist on the
control. Do you want to create and load the application?" The "Details"
button in this dialog leads to information on applications already availa-
ble on the control.

e The application is already available on the control and has not been
changed since the last loading. Login is carried out without further inter-
action with the user.

¢  The application is already available on the control, has, however, been
changed since the last loading. You are asked whether you want to
complete an Online change, page 133, or load the entire application or
login without changing the currently running application.

A dialog with the following text appears:
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do?

- Login with online change.
- Login with download.

- Login without any change."

The "Details" button in this dialog leads to information on the application
changed in the programming system as compared to its previous ver-
sion which is currently available on the control.

e  Another version of the application is already available on the control, is
however, currently not running. You are asked whether it is to be re-
placed. A dialog with the following text appears: "On the control, there is
an unknown version of the< Application name> application. Do you want
to replace it by the application in the project?".

The "Details" button in this dialog leads to information on the application
in the IDE (integrated development environment = programming sys-
tem) as compared to the one on the control.

e A version of the application is already available on the control and is
running. You are asked whether you want to login and overwrite the cur-
rently running application nevertheless. A dialog with the following text
appears:

"Waming: An unknown version of the <Application name> application is
currently running on the control. Do you still want to load the current
code and replace the existing application?"

The "Details" button in this dialog leads to information on the application
in the IDE (integrated development environment = programming sys-
tem) as compared to the one on the control.

Compilation before login  Before login and if the current application project has not yet been compiled
since opening or since its last change, it is compiled.

This means that it is compiled in the logged off condition as in a compilation
run, page 124, and a compilation code is generated for the control, as well.

If errors occur during compilation, a message box appears with the following
text: "Errors occurred during compilation. Would you like to log in without
loading the program?" This way, choose to correct the errors first or to log in
despite the errors in the most recent version of the application that might be
on the control. The errors are output in the message box in the "Compile" cat-
egory.

See also:

®  Compile, page 124.

Information on loading  If the project is loaded to the control completely at login or partially at online
change, information appears in the message window on the generated code
size, on the size of the global data, on the resulting memory requirement on
the control and in case of online change also on a list of the respective func-
tion blocks.

3.5.3 Logout o
lcon:

Default shortcut: <Ctrl>+<F8>

This command ends the connection between the development system and
the target system (control or simulated device) causing a return to offline
mode.
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3.5.4 Generating a Boot Application

Use in online mode:

Use in offline mode:

This command is available in online mode for generating a boot application.
A boot application (boot project) is started automatically when the control is
started. Itis named <ApplicationName>.app

The boot application is saved on the target device with the name <Applica-
tionName>.app.

The standard dialog for saving a file opens.

Select a directory for saving the current application as a boot application in
file format to load it to a target system at a later time. The file is a "boot appli-
cation" type file and the extension ".app" is automatically added to its name.
After confirming with "Save", another dialog appears, in which you are asked
if a "compilation protocol”, page 80 that might be present in the project direc-
tory should be overwritten:

IndraLogic '

-

o Bio you want to save the reference-context Far the bock praject?
'r) (il ceverwiribe the reference-of last downlosd)

Fig.3-44. Dialog for saving the compilation information for the boot application

Select "Yes" if you plan to transfer the new boot project to the control with an
external tool and you still want to log into the application without being forced
to download it again.

A compilation protocol from a previous download would not match the newly
created project, since it contains code and references from the previous ap-
plication.

3.5.5 Logging out the Current Online User

Icon: N

This command (User management) logs of the user currently logged in to the
project or the library. A corresponding message is output only if currently no
user is logged in. Otherwise, no dialog and no message appears.

If the user is currently logged in to several projects or integrated libraries (not
necessarily using the same user account), the following logout dialog is
opened.
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Yo arg-currently logged in b mofe than ong project ar library’
Please select from-which praject or lbrary wou want o logout:

projectfLibrary: | A
Clurrart User; |Lserl |
| ok || cancel |
Fig.3-45: Logout dialog

Via the selection list in the Project/Library field, you can now select the proj-
ect or the library from which the Current user is to be logged off.

The toolbar always shows the user currently logged into the project.
3.5.6 Editing Objects Offline in the Online Mode (Hijacking)

This command is only available in online mode with running or stopped appli-
cation.

If the user is logged in with an application, all opened PLC objects belonging
to this application are displayed in online mode. If another object is opened, it
is also displayed in the online mode.

The user can now in the context menu select the Edit object (offline) menu
item in order to also open the selected object in the editable mode.

g1 Project Explorer
B (2] Offfine_Ed
177 General module folder
&~ [l DCE Centel Expression Typs: Yalue | Preparedvalue | Comment S
=S LU% i INT 0 ?
B g
UsenvarGlobal Ll Lindf L. E
Library Manager B
233 oren | &
B- L‘E - : [
& : | i -
i| Drboard 10 o s [ = = _
il Infine 140 Y T e =
e Profibussh Expott. .. e I e T TS
B Micht_were Tmpork..,
Fig.3-46: Opening the PlcProg object for offline editing

Alternatively, this command is also available in the Debug » Edit object (off-
line) menu. It affects the POU selected in the Project Explorer.

As a result, the user has opened the object online and in the editable mode.
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PleProalDOC_Contiol Logie: Appheston] w X | PlcProg[DCC_Control: Logic: Applicati ¥ %
peE_Control.Application PlcProg | [ROGRAM PlcProg i
- VAR g
Expt=csion Type Value | Prepared valu &= 12 THT: g‘
i ot N % =
3 ] o .
¢} g = D VIR
4] | H
1 i 0 k=i 0 WaE: = -
z i 8 k=i o [|:[RETURN]
Fig.3-47: POU PlcProg online (left) and offline in the edit mode (right)

Any change in the right window is immediately displayed in the left window as
well without becoming effective in the program code or in the control.

PlcProg[DCC_Control: Logic: Applicati *
1 PROGRAM FPlcProg
= z VIR
5 3 i: THT:
T - [
! 5| mm var
1| | 4 —
1 i = dn s = S ‘(5_) =]
z 0 = i[ 0 |:[RETURN] z ji= i;
Fig.3-48: Offline change complefed

The changes made in the offline editor can be transferred to the control di-
rectly via the

e  Debug > Online change or
¢  Debug » Loading
menu commands, i.e. without log off and log in.

In the example, only the step width changes at the running application after
the online change.

After loading, the variables are re-initialized and after application (re)start,
counting is started at zero with the new step width.

I Note the following points before performing an online change:
e |[s the modified code free of errors?

e  Application-specific initializations (reference motion, etc.) are
not executed, since the machine retains its status.

e Can the new program code really work without re-initializa-
tion?

®  Pointer variables retain their value from the last cycle. If it is
pointed to a variable that changed in size, the value is no
longer correct. For this reason, ensure that pointer variables
are re-assigned in every cycle.

° If the active step in an SFC chart is removed, the chart re-
mains inactive.

At saving, the changes made are also retained at the interface in the project
without "Online change" or "Loading".
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If the project is under version control and the object opened "offline" is
checked in, it is brought into the "hijacked" state analogously to other objects
in the logged in state.

M Project Explorer
Offfine_Edll
| General module lolder

[ DCC_Cantral

= 2] Lo

- Wypiic:aisor [S TP
@ UszerdaiGiobal
Librari b anager
LE = B FicPiog FRGT
"4 Symbol configuration

= _,.L;a:j‘ Tazk Configuration
£ PloTask

1] Onboard|/0

1l Inling /0

e Profibuz/t

Fig.3-49: Display of the changed object in the Project Explorer

3.5.7 Load

This command is available in online mode. It triggers the compilation, page
124, and compilation of the active application, page 66,. This means that in
addition to a syntactic check, application code is generated and loaded to the
control.

= All of the variables, with the exception of persistent variables, are
re-initialized.

The following situations are possible:

If there is no application on the control yet, the user is asked if the application
is to be loaded to the control.

After the user confirms with "Yes", the "download" is performed.
A matching dialog appears during Login, page 127.

Indralogic =

?r) Application Application_1 does not exist on device | B wou wanttocreate itand proceed with download?

Fig.3-50: Message box, load application?

If other applications are on the control, the user is first asked if they are to be
deleted. Then the application is loaded. See the related description for the
same situation with the "Login" command.

If a different version of the same application is already on the control, the ac-
tive application is loaded, overwriting the previous version. If the versions do
not differ from each other, a dialog appears that indicates this situation and
the application is not reloaded.

Poligono Indutrial O Rebullén s/n. 36416 - Mos - Espafia - rodavigo@rodavigo.com



RODAVISS, 8.A. www.rodavigo.net +34 986 2388118

Servicio de Att. al Cliente

RODAMIENTOS VIGO, S.A.

DOK-IWORKS-IL2GPRO*V12-AP01-EN-P Bosch Rexroth AG 133/697
Rexroth IndraWorks 12VRS Indralogic 2G PLC Programming System

Menu ltems

Indral ogic '

"
I]) Pragram has mot changed, Mo onine change performed,
"l."‘

Fig.3-51: Message dialog, no download

3.5.8 Online Change

A CAUTION The online change modifies the running appli-

cafion program and causes a restart.

Depending on the system controlled, dam-
ages at the system and workpieces can result
or the health and life of people can be put at
risk.

Ensure that the new application code still results in the desired behavior of
the controlled system.

This command causes an explicit "online change" to be carried out for the
"active application", page 66,.

Online change means that only the modified parts of an application already
running on the control are loaded to the control. This cannot be done after
"Clean all" or "Clean"!

The cleaning deletes the compilation information that is automatically saved
during each compilation (build, code generation) and is the basis for an on-
line change.

An online change is automatically provided if login occurs with an application
that is already running on the control but has been modified since the most
recent download in the programming system.

See further information on "code generation and online change", page 80.
3.5.9 Start

Icon: ¥
This command starts the application on the control.

If the command is called from the online mode, the currently active applica-
tion is concemed.

If the command is called from the context menu if an application is selected in
the Project Explorer, login is carried out with this selected application even if
it is not set as "active application”.

3.5.10  Stop

Icon: W
This command stops the application on the control.
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3.5.11  Single Cycle

This command causes the active application to be executed for a single cy-
cle.

3.5.12  Multiple Download...

This command is available in online or offline mode. It triggers the compila-
tion, page 124, of and code generation, page 80, for all applications included
in the project intended by the user. This way, in addition to a syntactical
check of these applications, the related code is also generated and loaded to
the respective control. For each application selected for download, a corre-
sponding compilation protocol, page 80 named <projectname>.<device-
name>.<application ID>.compileinfo is generated in the project directory.

After the "Multiple download..." command is enabled, a dialog window opens
that displays a list of all of the applications included in the project:

Multiple Download E

Pleace gadact the applications for download;

w DCC_Contral 01:  Application
W DCC_Control 02:  Application

Oiine change ophicns:
IF the-application in th project differs from the spolicstion siready present of the-PLC,
then behave as follows: :

(% Try bo performan oniine change. If this is not pessible, perform & full downlnad:
" Force an online change, IF thisis not possihls, cancel the operation.
Ahizrs perform a full download,

-

IF an application & rot yet pressnton the PLC, a full dowrioad quwaw perfFormed,

—Additional operations: —
v Delete all applications on the PLC which are not part of the project,

v Start all applications after download or online change,

Fig.3-52: "Multiple Download” dialog

An application can be selected for download by placing a check in the re-
spective checkbox. Several applications may be selected, even if they are to
be loaded to different controls. By default, either all of the checkboxes are se-
lected or only those for the applications selected by the user for the most re-
cent download.

If a previous version of the selected application already exists on the control
and it differs from the current version, the following options appear for selec-
tion:

®  Try to perform an online change. If this is not possible, perform a down-
load. This option is selected by default. If it is selected, the modified
parts of the selected applications on the control are changed and only
the newly created parts of the respective applications are loaded to the
control.

¢  Force an online change. If this is not possible, cancel the operation. If
an online change for (at least) one of the selected applications cannot
be completed (e. g. if the command 'Clean all' or 'Clean application' was
previously executed), no download is performed.

e Always perform a download. All of the parts of the selected applications
are loaded to the control without taking existing versions into account.

Selected applications that do not yet exist on the control are automatically
downloaded to the related control.
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3.5.13

3.5.14

Reset Warm

Reset Cold

Menu ltems
In addition, by selecting the corresponding checkbox, users can specify if

e  Old applications that are no longer part of the project are to be deleted
from the control

e The selected applications are to be started after the download/online
change.

Note that PERSISTENT type variables are not initialized in general. However,
if the data layout was changed, the persistent variables are automatically re-
initialized.

After having confirmed the settings in the dialog with "OK", a syntactical
check of all of the selected applications is carried out. Then, for each applica-
tion, the communication with the related control is verified before the down-
load is carried out.

After the download is complete, a list of the selected applications appears,
which contains detailed information about the operations performed for each
application.

Multiple Download - Result

@ DCC_Control_01.Application Mot changed
@ DCC_Conkrol_0Z.Application Created

Close

Fig.3-53: "Multiple download - Result” dialog

This command is available in online mode. With the exception of the rema-
nent variables (retain, persistent), page 519, it resets all variables to their ini-
tialization value.

If variables were initialized with specific values, they are reset to these exact
values. All other variables are reset to the default initialization values (for ex-
ample, integer variables are reset to 0).

As a safety precaution, IndraLogic requires another user confirmation before
all variables are overwritten. The situation is comparable to a loss of power or
switching the control off and back on while the application is running ("warm
start").

A reset disables the breakpoints currently set in the project. If the "Warm" re-
set command is called just when the program sequence is stopped at a
breakpoint, the user is asked if the current cycle should be completed before
executing the reset or if the task should be stopped and the reset executed
immediately. However, not all runtime systems are able to execute a reset
without completing the current cycle first.

To start the application again, use Start, page 133 after the reset.
Also refer fo

®  Reset origin, page 136,

® Reset cold, page 135.

This command is available in online mode. It comresponds to the "Reset
warm" command, but in addition to the "normal" variables, retain variables,
page 519, (1) are also reset to their initialization values. The situation is com-
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parable to starting an application program that was just loaded to the control
("cold start").

A reset disables the breakpoints currently set in the project.

If the "Cold reset" command is called just when the program sequence is
stopped at a breakpoint, the user is asked if the current cycle should be com-
pleted before executing the reset or if the task should be stopped and the re-
set executed immediately.

However, not all runtime systems are able to execute a reset without com-
pleting the current cycle first.

Also refer to
° Reset warm, page 135,
®  Reset origin, page 136.

3.5.15 Reset Origin

This command is available in online mode. It resets the values of all inclusive
remanent variables, page 519, back to their initialization values and deletes
the application program from the control.

A reset disables the breakpoints currently set in the project.

If the "Origin" reset command is called just when the program sequence is
stopped at a breakpoint, the user is asked if the current cycle should be com-
pleted before executing the reset or if the task should be stopped and the re-
set executed immediately. However, not all runtime systems are able to
execute a reset without completing the current cycle first.

Also refer to
° Reset warm, page 135,
® Reset cold, page 135.

3.5.16  Breakpoints

m

This command opens the Breakpoints dialog providing an overview of all
breakpoints currently set in the project. The breakpoint parameters are dis-
played and can be modified. In addition, breakpoints can be added and re-
moved or enabled and disabled.

The first breakpoint parameters shown are those that were set using the
commands Toggle breakpoint, page 140, (here default values are set for the
breakpoint "conditions") or New breakpoint, page 138, in the "Debug" menu
(here the conditions can be defined directly).

Icon:

= If you have decided to use Multitasking, remember that by using
the breakpoint you only stop the one task in which the breakpoint
is located.

I Breakpoints

Application:  Application [DCC_Contral_01: Logic]

- O
- | Wlhew ¥ B | ER | =1 S B8 O

PoL

| Location | Instance path | Tasks | Condition | Current hit count |

(9] |FBfST [DCC_Control_01: Logic: Application]

‘Line 1, Column 1 {Impl)  DCC_Control_01,Sim.DCC_Conkrol_01. Application. Plc_Main.fb_st_01  {any) Break when the hit count is greater than or equal ko 33 3

@ Plc_Main [DCC_Control_01: Logic: Application]  Line 1, Column 1 iImpl  {any) fany) Break always a
@ Plc_Main [DCC_Control_01: Logic: Application]  Line 4, Column 2 (Imply  {any) PlcTask  Break always o

= cutput | 2 Task List | Search resuls | 3 Crass Reference List | Eedwatch 1 | &% ereakpoints |

Fig.3-54: "Breakpoints” dialog

Poligono Indutrial O Rebullén s/n. 36416 - Mos - Espafia - rodavigo@rodavigo.com



&

D ROBAVICS, S.A. www.rodavigo.net +34 986 288118

2,

N "‘7 :
fom Servicio de Att. al Cliente

RODAMIENTOS VIGO, S.A.

DOK-IWORKS-IL2GPRO*V12-AP01-EN-P Bosch Rexroth AG 137/697
Rexroth IndraWorks 12VRS Indralogic 2G PLC Programming System

Menu Items
Description Example
Application Name of the active application Application [DCC_Control_01: Logic]
POU Name of the function block that contains the breakpoint Plc_Main

Breakpoint position within the POU: line and column number
(text editor) or network or element numbers (graphical edi-

tor);
Position ) ) o Line 4, column 2 (Impl)
In the case of function blocks, "(Impl)" indicates that the

breakpoint is located in the implementation of the function
block, not in an instance.

DCC_Control_01.Sim.DCC_Con-

Instance path Complete object path of the breakpoint position trol_01.Application.Plc_Main.fb_st 01

Names of the tasks in the execution of which the breakpoint
Tasks becomes effective. PlcTask

If there is a limitation (default), "(all)" is listed here.

Indicates when the breakpoint becomes effective (depend-
Condition ency on number of hits); for possible values see New break-
point, page 138, (Default: 1).

Break if the number of hits is greater than
or equal to 33

Current Indicates how often the breakpoint has been ("hit") during 3
Number of hits | the execution up to this point.
Fig.3-55: "Breakpoints” dialog, description

The following functions are available by using the buttons in the upper right
part of the dialog. They are used to edit the breakpoint parameters of the
breakpoints selected in the list or to add new breakpoints or delete them:

Opens the New breakpoint dialog

tfiNew | New breakpoint See also the description of the corresponding New breakpoint, page 138, com-
mand.
) Removes the breakpoint;
x Delete breakpoint ) ) ) ) ]
Attention: do not confuse this function with "Disable"!
Switches back and forth between the "enabled" @ and "disabled" (' status.
A Enable/disable breakpoint In case of disabling, the breakpoint is not removed from the list and can be en-
abled again.
Opens the "Breakpoint properties" dialog where the breakpoint parameters can

EEhy Properties be edited. The dialog is comparable to the "New breakpoint" dialog; see New
breakpoint, page 138, for a description.

Opens the "Select online status" dialog; from where you can move to the posi-

= Go to source code position tion of the breakpoint in the source code.
] Deletes all breakpoints in the application The list is emptied.
%’]] Delete all breakpoints ) ) ) ) )
Attention: do not confuse this function with Disable!
) Enable all breakpoints Enables () all breakpoints that are currently disabled
“'I-@J Disable all breakpoints Disables (Z%) all breakpoints that are currently enabled. The breakpoints remain

in the list and can be disabled again.

Fig.3-56: Symbols
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3.5.17  Breakpoint Positions

Possible "breakpoint" positions, page 82, depend on the type of editor.

In principle, these include any position in a POU where the values of varia-
bles can change or where the program flow branches or another function
block is called.

= A breakpoint is always automatically set in all methods that can
be called

that means that if a method managed by an interface is called,
the breakpoints are also set in all of the methods of the function
blocks that implement the interface and likewise in all of the func-
tion blocks derived that use the method.

If a method is called using a pointer to a function block, break-
points are set in the method of the function block and in all of the
function blocks derived that require the method.

Breakpoint symbols:

[

14l

[ ] -Zl:=fhinsi

TF hrarvEal<Fl THRT

° Breakpoint in online mode:

e

[

141} ;

i -: =fbins-

TF hwarFalsF THRI

I-1

L Disabled breakpoint:

[0

[

141();

© krof 0 J=fhinst

TF hwarFalsFl THFRE

° Program stop at breakpoint:

I-)

[0

Also refer fo

®  Breakpoint positions in the IL/LD/FBD editor, page 365
®  Breakpoint positions in the CFC editor, page 317

®  Breakpoint positions in the ST editor, page388

3.5.18  New Breakpoint
Icon: i@

Menu: Debug » New breakpoint...
This command is used to define a new breakpoint, page 82, in the project.

It is not relevant where the cursor is currently positioned, the 'New breakpoint'
dialog opens where in the Position sub-dialog, one of the possible breakpoint
positions in the entire project can be selected and in the "Condition" subdia-
log, certain conditions can be defined for the breakpoint becoming effective.

To set a breakpoint at the current position, also use the Toggle
breakpoint, page 140, command or the corresponding function in
the Breakpoint dialog, page 136,.
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New Breakpolnt B

Lacatian ] Cordition |

PO |FB_ST [DCC_Cantrol_01: Logic: Application] =

Pt |Unn? L, Colamn 1 (Impl) _:]

v Trskance Pathi |DEC_C.TrnI‘.r-jI_E|1.Sim.DCIZ_C.T.nr.r-jI_Ell..ﬁ.ppllu'_al:iuru.F‘Ic_Main.Fb_ﬂtj

[~ Enable Breskpoint nmediataty ok I Cance|

Fig.3-57: Dialog - "New breakpoint”, position

POU: The selection list provides all of the POU objects in the project.
Select the POU object in which the breakpoint is to be set.

Position: The selection list provides all of the possible breakpoint posi-
tions at the selected POU in the "POU" selection list; see Breakpoint po-
sitions, page 138. Depending on the type of editor, these positions are
listed as line and column numbers (text editor) or as network or element
numbers.

For function blocks, "(Impl)" is also displayed.

The breakpoint can be set in the implementation or in an instance. If it is
to be set in the implementation version, leave the "Instance path" option
disabled. If it is to be set in an instance, enable the "Instance path" op-
tion to select the instance.

Instance path: If the POU selected above is a function block and this op-
tion is disabled, the new breakpoint is set in the implementation version
of the function block. If the breakpoint is to be set in an instance, enable
this option and select the desired instance.
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New Breakpoint E l

r- Enabls breakpoirt i Edighel I Cancel I

Location  Condition |
Tashs:
i Only bresk if the brealqoint is hit i ohe of the Fallowing tasks:

—Hit Count:

{Breal when the hit count is greater than or equal bo :_I I a3 53
—{Break shvays
Break when the hit count is egual to
Break, whan the hit count is & multiple of
Ereak when hE- hit count 15 greater than er egual to

Fig.3-58: Dialog - "New Breakpoint”, condition

Tasks: If you enable the option "Only break when the breakpoint is hit in
one of the following tasks" (by default: disabled), the breakpoint only be-
comes effective if the POU in which it is set is executed by one of the
tasks selected here. All of the tasks defined in the project are listed and
the desired tasks can be selected by placing a checkmark in the check-
box.

Number of hits:
—  Always break: The program always stops at this breakpoint.

Alternatively, a number can be specified that indicates how often the
breakpoint has to be hit before the program stops in accordance with
the following conditions at execution.

—  Break when the hit count is equal to

—  Break when the hit count is a multiple of

—  Break when the hit count is greater than or equal to
the "number".

Toggle Breakpoint

Default shortcut: <Alt>+<F9>
Menu: Debug * Toggle breakpoint

In principle, this command is used to switch back and forth between active
and inactive status for a breakpoint, page 82.

However, it also can set a new breakpoint if none has already been set at the
current breakpoint position, page 138,.

See New breakpoint, page 138.
If an active breakpoint is already present, it is disabled.

If an inactive breakpoint is already present, it is enabled.

= Every active breakpoint becomes inactive when a user exits the

online mode and then logs in again.
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3.5.20 Call Stack identified by a ' symbol.
Icon: &

This command opens the window with the call stack. When a program is exe-
cuted step by step, the current position is always displayed here with its com-

plete call path.

Below the title line, the window always displays the name of the active appli-
cation and the name of the task which is controlled by the POU that was just

reached.

The call stack consists of a list of positions, each described by the POU
name, the position and - in the case of instances - the instance path. De-
pending on the editor, the position is indicated by line and column number
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An active breakpoint is identified by a ® symbol; an inactive breakpoint is

(text editor) or as network or element numbers (graphical editor).

The first line in the list, indicated by a yellow arrow, describes the current ex-
ecution position. If this position is located in a function block that is called by
another function block, the position of the call is described in the second line.
If the caller is then called by another function block, this call position is descri-

bed in the third line, etc.

The call stack is also available in offline mode or in normal online operation
(without having to use debugging functions). In this case it contains the most
recent position indicated during a step by step execution, though it is dis-

played in a "grayed out" font.

Applicaione. DCC Control 1. Sim DCC_Contrel 0 Application

Tagk. PLCTASK

oY

% FBE_S5T [DCC_Control 01 Logic: Appiication]
Ple_Man [DCC_Contiol 0N: Logic: Applicat.

Location
Lare 1. Calurnin 7 [Impl]
Lire 2, Column 1 [mpl]

| = FaskList | Search restits FAwatch 1 | Plerestpuints | B cal stack

| Instancepath
Flz_Mam.ib_st_01

Fig.3-59: Call stack, current posifion of FB_ST, called by Plc_Main

3.5.21  Monitoring

This command opens a submenu with the five commands described in the

following.
Watch 1, Watch 2, Watch 3 and Watch 4.
Expression Type Walue Prepared value
= DCC_Control_01, Application Plc_Main - PLC_MAIN
& ivar_01 INT 2
& Var Dz NT i}
& bhar_01 BOOL
= @ [fb_st_01 |Fe_sT
4% iInput INT 2
" i0utput INT 1
& Task List | search results @Watch 1 @Breakpnints | ﬁCaII Stack |

Fig.3-60: Example of a watch list in online mode
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In this way, the respective monitoring list can be opened in a window and
edited, page 499,.
In addition, Watch all forces can be used to get an overview of all of the per-
manently affected variables.
r1watch all Forces
UnFarce... - |
Unforce all selected Expressions, without modifying the value, Tiﬁe Walue
Unforce all selected Expressions and restore the variable o the value it had before Forcing it INT 33
Fig.3-61: Example, "Watch all forces”
3.5.22 Procedure Step
lcon: L=

Default shortcut: <F12>
Menu: Debug »> Procedure Step.

This command can be used to execute a program in defined steps in online
mode (Stepping, page 82), e.g. to make troubleshooting easier.

A single step is executed. For single step instructions, this is comparable to
"stepping" with "single step"; see Single step, page 142.

If a function block call is reached, "Procedure step" causes the function block
called to be completely processed within the current step.

A complete action is processed in one sequence diagram.

If you only want to execute one step to the first instruction of a called function
block, you have to use the Single step command, page 142,.

Also refer fo
®  Execute to return, page 143.

3.5.23 Single Step

Icon: *=
Default shortcut <Alt>+<F12>
Menu: Debug > Single Step.

This command can be used to execute a program in single steps in online
mode (Stepping, page 82), e.g. to make troubleshooting easier.

A single step is executed. The program stops before the next instruction. If
required, it is switched to another POU. If the current position is a function or
a function block call, it is stopped before the first instruction of the function
block called.

In all other situations the command has the same effect as a procedure step;
see "Procedure step”, page 142.

Possible stop positions during single step processing depends on the editor
type. The current position is displayed with yellow shadowing.
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1| 1dl():

z ergl 0 |i=fbinst.ic
Z|e» IF bvarFalsE] THEH

4 ivarl[ 45 |r=23;
£ ELSE

&

b

ivarl[ 45 |r=d5;
E ;m T .

Fig.3-62: Example of a single step
3.5.24  Execute to Return

lcon: ®=

Default shortcut: <Shift>+<F10>

Menu: Debug > Execute to Retum.

This command can be used with a step by step execution of an application
program (e.g. for debugging purposes).

If the program does not include any calls, the command 'Execute to return’
causes a jump back to the start of the program. If, however, a jump was
made previously into a called function block, it triggers a jump back to the
calling instruction (note:. This is new compared to IndralLogic 1.x).

This way, in the case of nested calls, 'Execute to return' takes effect step by
step backwards in the hierarchy of the caller. This allows to jump back one
step in order to jump into another called POU from there, for example.

Also refer fo
®  Single step, page 142,
®  Procedure step, page 142.

3.5.25 Execute to Cursor
Icon: +=
Default shortcut: <F7>
Menu: Debug » Execute to Cursor.

This command can be used to execute the program up to a temporarily de-
fined position (e.g. for debugging purposes).

The effect is the same as when the next breakpoint is defined at this position;
see "New breakpoint", page 138.

The instructions located between the current and the newly defined position
are executed.

3.5.26 Determine Next Instruction
Icon: $

Menu: Debug » Determine Next Instruction.

This command can be used with a step by step execution of an application
program (e.g. for debugging purposes) in order to define the instruction that
is to be carried out next.

To do this, position the cursor in the instruction that is to be executed next
and trigger the command.

3.5.27 Display Next Instruction

Icon: &
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This command can be used in online mode to move back to the current exe-
cution position if the cursor was placed somewhere else in the user interface
during the step by step processing of a program. The window of the corre-
sponding function block is brought back into the foreground and the cursor is
placed in front of the next instruction to be executed.

3.5.28  Write Values for All Online Applications

Default shortcut: <Ctri>+<F7>
Menu: Debug > Write values for all online applications.

A CAUTION The extraordinary modification of values in an

application running on the control might lead
to unwanted behavior of the controlled sys-
tem.

Depending on the controlled system, damage
at the system and workpieces might result or
the safety of persons might be endangered.

Evaluate possible risks before writing or forcing variable values and take cor-
responding precautions.

"Writing" a value with this command means that at the beginning of the next
cycle, the corresponding variable in the control is set to the value defined for
it in the programming system.

= For more information, see also the "Force values" command used
to set the variable values permanently in the control.

To prepare variables for writing, the desired value has to be defined in online
mode at one of the following positions used for monitoring, page 82,:

¢ |n a monitoring window that was defined in the project and that contains
a list of the variables to be monitored (monitoring list, watch list, page
499).

¢ |n the online view of an object in the declarations, page 330, of the as-
sociated editor

Example:

Write values

Open an object in online mode, e.g. a program written in ST.

The expressions (variables) that can be monitored are displayed in a table in
the declarations.

Click on the corresponding field in the Prepared value column and enter the
desired value.

Then execute the Write values command that is in the Online menu by de-
fault.

The prepared value is then entered in the same line in the Value column,
which indicates that it was written to the control.

The "Prepared value" field is now empty again.

The same action can be performed in a monitoring list, watch list, page 499,,
which contains the corresponding expression or variable.
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In this context, also note the Prepare value, page 145 dialog, which can be
opened for the variables that were just "forced" and in which a new value can
also be defined for "writing".

3.5.29 Force Values on All Online Applications

Menu: Debug » Force values on all online applications.

A CAUTION The extraordinary modification of variable val-

ues in an application running on the control
might lead to unwanted behavior of the con-
trolled system.

Depending on the controlled system, damage
at the system and workpieces might result or
the health and life of persons might be at risk.

Evaluate possible risks before writing or forcing variable values and take cor-
responding precautions.

This command is available in online mode. It causes one or more expres-
sions (variables) in the application on the control to be permanently set to de-
fined values.

This setting is then carried out once at the beginning and once at the end of a
processing cycle.

Sequence of the process in a cycle:
1. Read inputs

Force values

Process code

Force values

Wirite outputs

S

= See also the Write values, page 144 command used to make the
setting with a defined value only once at the beginning of the cy-
cle.

The forcing is performed until the user cancels it explicitly for a single variable
or for all variables or until the user logs out of the application.

To prepare variables for forcing, the desired value has to be defined in online
mode at one of the following positions used for monitoring, page 82,:

¢ |n a monitoring window that was defined in the project and that contains
a list of the variables to be monitored (monitoring list, watch list, page
499).

¢ |n the online view of an object in the declarations, page 330, of the as-
sociated editor

e |n the online view of an object within the implementation section of the
FBD/LD/IL editor, page 362.

A "forced" value is indicated by an @ symbol.
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PLC_PRG
PLLC.Application.PLC_PRG
Expression Type Yalue Prepared walue | #%
+ o fhinst FE1
@ erg INT 0
@ bvar BOOL [F | TRUE]
@ iear NT 222
Fig.3-63: Example of forced variables in the declaration editor of a function

block (online view)

This dialog is used to define a new value for a variable. To do this, either a
new value is entered or forcing is canceled and the value returns to the cur-
rent or previous value.

The dialog opens when clicking the "Prepared value" field of a variable that
has just been forced

PLC_PRG 4 x
PLC.Application.PLC_PRG

Expressian Tvpe Yalue Prepared walue | A

+ 4 fhinst FB1
@ erg INT y
# bvar BOOL /
@ ivar INT 22z

Fig.3-64 Example of forced variables in the declaration editor, click "Prepared
value”

or in the Inline monitoring field of the variable in the implementation section of
the FBD/LD/IL/ST editor.
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ivarJiseiE= ivar[JBEL] + L: countas
thinatl f*!ﬁ{ B! : 121l instl with 12
erg 2@ = thinsvl.oud 0 i rezplt fhinstl
fhinst? (in] 22 W =20): 211 fhindt2 trith 22
ergl 2 L= thinadg.out & |; /¢ resukt fhinst :
T Prepare Value
{HETLIRMI
Expression: iMDﬁonPrng.ivar
Typa: ;JNT
Current walas: !3141'8
~Whiat do you vant to do?
{* Preparea newvalue For the net virite or Force aperation:
{0 He=nmee oY Eparation W
{71 Release the force, without modifying the value,
Release the Farce and restore the variable bo the value it had
Befare foreing it
[a]4 I Cancel
Fig.3-65: "Prepare value” dialog

The following information on the respective variables is displayed:
e  Expression: Path: e.g. "PLC.Application.PLC_PRG.ivar"

e Data type: e.g. "DWORD"

e  Current value: e.g. "TRUE" or "23"

Select one of the following options to determine what should happen with the

variable:

e  Prepare a new value for the next write or force operation: Depending on
the data type of the variable, a new numerical value or string value can

be entered to which the variable is to be set.
¢ Remove preparation with a value: The prepared value is deleted.

¢ Release the force without modifying the value: The variable is marked
with <Unforce> and thus prepared to receive the current value from the

control.

o Release the force and restore the variable to the value it had before
forcing it: The variable is marked with <Unforce and restore> and thus

now prepared to receive the value that it had before forcing.

After closing the dialog with "OK", the variable in the "Prepared value" field in
the monitoring view(s) now indicates a newly defined value or "<Unforce>" or
"<Unforce and restore>". Then next time the "Force values" or "Write values"
command is carried out (for the first option), all of these prepared values are

set.

3.5.30 Cancel Forcing for All Values on All Online Applications

Menu: Debug » Cancel forcing for all values on all online applications.
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A CAUTION The extraordinary modification of variable val-

ues in an application running on the control
might lead to unwanted behavior of the con-
trolled system.

Depending on the controlled system, damage
at the system and workpieces might result or
the health and life of persons might be at risk.

Evaluate possible risks before writing or forcing variable values and take cor-
responding precautions.

This command can be used in online mode to cancel forcing for all of the var-
iables currently being forced for the applications included in the project.

The variables then receive their current value(s) from the control.

This corresponds to the option "Release the force without modifying the val-
ue." that can be selected in the Prepare values dialog for a forced value.

3.5.31  Add All Forces to Monitoring Window

This command is available in online mode as soon as one of the four moni-
toring views, page 141, "Watch 1", "Watch 2", "Watch 3" or "Watch 4" is ac-
tive.

It adds all of the variables in the current application that are now prepared to
be forced or have already been forced to the watch list.

Please note, however, that this only works for docked monitoring views.

Also note the "Watch all forces" view, which automatically and continuously
displays all variables that have been prepared for forcing and also provides
commands for canceling the forcing.

3.5.32 Sequence Control

Menu: Debug » Sequence control.

This command is used to switch the sequence control on and off which is
supported for the ST, FBD, LD and IL language editors.

An activated sequence control allows to track the processing of the applica-
tion program.

1. The current values of the variables and thus also the results of function
calls and operations are displayed in the editor windows, at the relevant
processing position and at the relevant processing time. For compari-
son: The standard monitoring only provides the value of a variable be-
tween two processing cycles.

2. Exactly the code lines or networks are marked in color that have been
run through in the current cycle.

The sequence control can only be activated in online mode and only works in
the currently visible part of the currently active editor window. 'Sequence con-
trol activated' is displayed in the status line as long as the function is active
and sequence control positions (parts of the code run through) are visible in
the editor window.
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= An activated sequence control extends the application runtime!

If the "Secure online operation" option is enabled in the "Commu-
nication settings" of the control, a message box appears upon se-
quence control switch-on. You are asked whether you really want
to activate the function and are once again provided the possibili-
ty to cancel the process.

llustration of the sequence control in the different language editors:

By default, green is configured as color for marking the sequence control po-
sitions. (The color can be changed in the Text editor options, page 218,.)

In all editors, the current values of variables and inputs and outputs con-
cerned are displayed in small rectangular fields as they are also used for the
standard monitoring. In code parts run through, these fields are displayed in
the color defined for the sequence control, in code parts not run through, they
are shown in white with grey font.

Please note that the displayed value at a code position not run through is a
"normal” monitoring value, i.e. the value between two task cycles.

i[ 1813 | := i[ 1819 | + 1:

b[o ] := HOT b0 |;

IF =tr| ‘abcdefghii b | = strl| B | THEH
£12 := £l ;

ELSE

£12[ 18 |r=1.5;:

D[ 65E+4 b |: =BRSS*BRSS];

EHD TF';

IF D[ 65EH4 » k0.0 THEW

W -1 Ton e W

Flig.3-66: Example: Sequence conftrol in the ST edifor

In network editors, the networks run through are marked at the left edge by
means of bars in the 'sequence control color'.

In the LD, the connection lines currently run through are generally shown in
green (or the 'sequence control color' currently set), the other ones in gray.

The current value of the connection is shown, as well:

¢ TRUE by means of thick blue,

. FALSE by means of thick black lines,

¢ unknown or analog values by means of thin black lines.

Due to the combination of the relevant information, this might lead to dashed
lines.
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Counter + - 1 |_ —
1— Counter

MUL
Amplitude % Z00
2 —]
Amplitude
£
GT )
divalue > @
Value
&
LT Dowm
divValue < ()
Value
Fig.3-67: Example: Sequence control in the LD edifor

In IL, two fields are used for each instruction to display the current values.

The field on the left side of the operator contains the current accumulator val-
ue, the field on the right side of the operand the operand value.

1

CAL TL{
IHr= T2.0,
PTr= TH2a,
ET=» ET1)

T T80

Tz.IN

TE |
FT:= T#ls,
ET=> ETZ)

T2.0

I s Blink

Cl
T THv0duns

=3
&

TEls

CAL Inst|
Enahle:r= TRUE,
Luplivude:s= 100,
GoHome:r= Blink,

TIOUE

Up=2 Tp, FALEE
Dowh=2> Down) I
LD Inst.¥alue
[ 7 st X
CAL Insta(
Fanelnl o

Fig.3-68: Example: Sequence control in the IL editor
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@ Note that writing values is also possible in the sequence control
v mode.

Forcing is not possible!

Double-clicking the value display field opens the Prepare value,
page 145, dialog to enter the desired value.

3.5.33 DISpIay Mode This command can be used to set the format for displaying the values (Moni-
toring, page 82) in online mode.

To do this, click on the desired option, which is then displayed with a check-

mark.
e  Binary
° Decimal

° Hexadecimal

3.6 Tools
3.6.1 Comparison of PLC Objects

Comparison of PLC Objects, General

The Compare... menu item provides the option
1. to compare PLC objects of the current project with each other,

2. to compare PLC objects of the current project with those of an export file
(*.iwx),
3. to compare PLC objects of two export files with each other.

In the first case, the desired objects are to be highlighted in the Project Ex-
plorer.

In the second case, the desired object is to be highlighted in the Project Ex-
plorer and "Compare..." is to be selected in the context menu of the object. In
the appearing window, the desired export file has to be selected.

To compare two export files, the menu item can be accessed in
Tools » Compare... .

The description is made based on the combination of project/export file. This
applies similarly to export file/export file.

If the comparison cannot be made, since the object types differ, an error
message appears.

Basics of the comparison in IndraWorks Engineering:
®  Rexroth IndraWorks 12VRS Engineering,
DOK-IWORKS-ENGINEE*V12-APxx-EN-P, R911334388.
® -  Toolbarin the "Compare" dialog, page 110.
—  Toolbar in the" Comparison results" dialog, page 111.
Comparison of PLC objects
®  General module, page 152
® |ogic, page 153
®  Application, page 154
®  Task configuration, page 157
® Task, page 152
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®  Folder (Difference from IndraWorks folder), page 159

e Data types, page 159

° Global variable list, persistent variables, network variables, page 161
. Network variable lists, receiver end, page 162

. Programs, function blocks, functions..., page 163

® Interfaces, interface methods, interface properties, page 169
e Library manager, page 170

®  Libraryinfo, page 172

° Data server, page 173,

e Data source (data server), page 174,

e  Symbol configuration, page 175,

e Visualization manager, page 175,

e  Visualization, page 177

e Textlist, page 177

® |mage pool, page 177

®  Recipe manager, page 177

®  Recipe definition, page 179

° Devices (Onboard I/O, Inline I/O, field busses, ...), page 179

Comparison: General Module

Here only the name is displayed in the window. "Merging" is not possible,

since the element is fixed.

Differences can result based on the name or language.

m Froject Buplorer
B 2] Prof_Campare
[ General maduls falder,
4?l;..i'irnilll:lg_‘lE_Input-_D'E'utiEl
“i# Analog Data
=] GetBooleanFropeity [FLIN)
=] GetCompary [FLIN]
=] GethumberProperty [FLIN]
=] GetTestProperty [FUN]
=] GetTitle [FUM]
=] Getversion [FLN]

<ELIRTFIRIR

Propetties | w Duect sub-elemerts |

s okt P

Z] GetversiorPropery (FUN) Cloge’ | Help |
E¥ Library Info Z
Fig.3-69: Comparison. General module folder
™. Comparison =l
B0 MA
Properties |
Foszi.. General module folder [Froject] Posi.. General module folder [File)
Oﬁ| 1 Analog 16_|nput_Data 1 Analog_16_|nput_Data
%II 2 Analog Data 2 Analog Data
“| 3 Project Infarmation 3 Praject Infarmation
| 1 Matchies) " 2 Differencels)
Compare all Sub-elements I Cloze | Help I
4

Fig.3-70:

Comparison: Listing of the "Direct subelements’, two elements with
differences (red)
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If the assignment in the columns of the two objects differs, can be used

to select the next difference ( for the previous difference).

If the checkmark appears, it can be used to prepare the acceptance
(merging):

Select the hammer to merge.

Select the cross E to prevent (undo) merging.

= The terms "Project Information" and "Library Info" designate the
same element.

Comparison: All subelements
.
|eals
Left Etements (Fraec] Flight Elements (Fils]

| Genesal modiss foldes | General module folder- |
@ Anzion 18 Input Dala | Analog 15_Inpul_Data

_‘5-:' [ista | &malog_Diata

nl‘-'ﬁ'ﬁi! ritcarrstion :F'-'-'-]ﬁf' |nfermation

Fig.3-71: Comparison. "All subelements’, two elements with differences (red)
. . with filter option "All elements”, "Different elements”, "Identical ele-
Comparison: Logic ments”

Here only the name is displayed in the window. "Merging" is not possible,
since the element is fixed.

!‘wﬁ!‘!“"" . -_ Comparison !E[ E
= Proi Compare — -
= 3 Genesal module folder A " |
o E_} Miclipes Propatties I ® Ditect suib-elements |
= Zif Loge
= I Application Elemant Logie (Project] | Logic {File]
= Falder 01 N ame | Logic | Logie
# G¥i_Sender
@ MicVaGiobal = —
b UzeiVaiiohal 1 Matchies) | O Dirfer ean(::_'_\'
Libwary Manage:
@] MotionFrog_FBD FRG] Compare all Sub-elements Close Help |
totionFProg_FUP [PRG) | ‘ Y
Fig.3-72: Comparison. Logic
A Compatison H=] E3
Properties M Direct sub-slements |
Fozi..  Logic [Project] Pozi..  Logic [File]
":,. 1 |.-’-‘«|3plicati0n | 1 |.f1‘-.pp|icati0n
J 0 Matchies) ” 1 DiFFerence(s)J
Compare all Sub-elements Cloze Help |
P
Fig.3-73: Comparison: Logic with one single subelement "Application”
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Comparison: All subelements

| "., Comparison Results
==
Ifjﬂ Lzit Elemants [Praject] Fiight Elements {Fils]
=il Lagic Logic
| Application Application
o Datahener FRG
|5 Falder_o1 Falder_01
| vl Sende GYl_Sender
| UserviGiohsl UsetyarGlobal
m Library Manager Library Manager
] | MotionPrag_FBD MofianProg_FED
4] | MationProg FUP MationProg_FLF
i MohonPra MationPro
[2] | MotionFrog MationProg
5] | PicProg PlcFrag
I. 8| SymbolConfiguration SymbolConfiguration
I@ T azk Configuration T azk Configuration
& DatazerverT ask
2| MotionT ask MiotionT ask
2| PlcT ask PlcT ask
T Perzsistent'f ars Persigtenty ars

Fig.3-74:

Comparison: Application

ments"” "Different elements” "ldentical elements”

Comparison. Logic with all subelements with filfer option "All ele-

Here, the name is displayed, the options for the boot project handling and the
other application properties. These are located under Properties in the "Appli-
cation" node context menu.

mm Froject Brplorer

E- @F‘m{_tompare
& (23 General madule folder

= [ Miet
B+ 5l Logie
17 Folder_01
@ GYL_Serder
@ MlcvarGlobal

o UservarGlobal
) Libram tanages
i MotionFProg FED (PRG)
i MatisnProg FUP [PREG]
=] MotiarPro (PRE]
MatiorFrog [PRG)
=] PlcFiog [PRG)
I 8 Syl ranfiguratinn
= @ TaskCDrifigu;ation'
I hotionT azk.
i PlcTask
T Persistentyars

"_ Comparison

G-8 00 Man

" F!rfmmsl u Eurmtpmparm|l Bnmuﬂ:«&amm|

 Elsment Application (Projest]. Application [Fi=).
Bizal spphcation impled duting dowrlosd False Trug
Bool application implied during online charige | False False
Boot applization prompt upon closng the project | True Trus
| 2Mateh{es) | 1 biferencels)
Cormsalsibobmenss | G | |

Fig.3-75:

Comparison. Application

If the assignment in the columns of the two objects differs, can be used

to select the next difference ( for the previous difference).

If the checkmark appears, it can be used to prepare the acceptance
(merging):
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Select the hammer to merge.

Select the cross E to prevent (undo) merging.
The next tab shows the build properties.

s COmparison
ST VTR
Exchudefiombuld | Fabe Fabe
Exemal mplementation | False Fale
Ailow sustem cali False False
Always link Falze Falze
Compiler definitionz Test_\ar=TRILE
| 4 Makch{es) || 1 DiFFerence(s)|
Compare all Sub-elements | Cloze | Help |
Y
Fig.3-76: Comparison: Build properties object 1/object 2, one difference ident-

fied and marked in red
If the assignment in the columns of the two objects differs, can be used

to select the next difference ( for the previous difference).

If the checkmark appears, it can be used to prepare the acceptance
(merging):

Select the hammer to merge.

Select the cross E to prevent (undo) merging.

The "DataServer_PRG" program (right position 7) is missing in the project
and is to be taken from the file.

"GVL_Sender" differs with regard to the content and the order of the objects
is different from position 7.
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. Comparison
-Bpanan
g | 7 |DaisSever PG
=k | Folder_01 1 Feider_01
2 |GULseds Z | EYL Sender
@ | UssiVaGlohsl 3| Usetvarflobal
Iu 4 | Library Manager 4 Library Manage!
#'5 | MoborPog FED 5 MahorProg_FBD
5l | MotianPiog FUP B |MotionFrog FUP
' MohorFro g MohonPra
| MotionPiog 5 |MctonFiog
| PicFiog W |PlcPiog
10| SymbolConfioation 11| SymbolConfiguation
& 11 | Task Configuation 12 |Task Configuration
T 12 |Perilenlas 13| Persistenivars
[ Ststch(es) | 8 Daferecets) |
A
Fig.3-77: Comparison. "Direct subelements”

If the assignment in the columns of the two objects differs, can be used
to select the next difference ( for the previous difference).

If the checkmark appears, it can be used to prepare the acceptance
(merging):

Select the hammer to merge.

Select the cross E to prevent (undo) merging.

" Comparison E[ E

E-apgEan
 Popeties| ®m Buld properties ® Ditme subslements | _
| DataSever PRG 7 |pataSewer PRG
=1 Falder_1 1 Falder_01 -
@2 Gvl Sende 2 |GV Sender -
| 5 Matchies) ” & Differencels) |
Compare all Sub-elements | Claze | Help |
Vi

Fig.3-78:

Comparison: File is accepted into the project with "Start merge opera-
tion”
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BEal=
Left Elements [Prgject] Fiight Efements [File]

G Application Application

@ DataSener FHE
|| Folder_01 Folder_(1

a YL Sande YL Sender

@ | UsetvarGlobal Uservarlobal

|m Library fdanaget Library M anagec

1] | MationPrag_FBD MetionProg_FED
] | MotionProg_FUP MeticnProg_FUP

=] | MationPra MotionPro

5] | MationPrag MeticnPrag

Ei FlzFrog FlzFrog

= SymbolConfiguration SymbalConfiguration
@ Task Configuration Tasktorifigusalion:
B DalaeyeT ok

&2 | MotionT ask MationT ask.

S PloTask PloT ask

T | Peczistenty ars Persistentars

Fig.3-79:

Comparison. Application with all subelements with filter option "All ele-
ments”, "Different elements”, "ldentical elements”

In addition to the direct subelements, their subelements are displayed, as
well. Here, the "sub-subelements” of the task configuration (DataServerTask,
only right, MotionTask and PlcTask).

Comparison: Task Configuration

Here only the name Task configurationis displayed in the window. "Merging"
is not possible, since the element is fixed.

5 Falder_01
GYL_Sends
MicWarGiobal
UzervaGiohal
Libirary Manager
] MetiorProg FED [PAG)
MuoticrFrog FUP [FRG]
g MohionPro [PRG]
(5] MotionProg [PRG]
ﬁ FleFrog [PRG)
% Symbal configuration
=] iﬂ Tk, Configuistion
@ MotionT ask
o g5 PlT ack
S— PersistentVals

L
- | ompar 1S0n

G-8oaaaa

Propetties | w Diect subelements |

Element Task Contiguration (Froject) | Task Configuation (File)
Name Task Eonfiguration Tack Configuiation

[ 1ateftes) | @ pferenes() |

Help.

Fig.3-80:

Comparison. Task configuration
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) -
- Lomparison

C-gnamog
Propeties | 8 Direct ubslemenis |

- Posti Task Corfiguration [Project Posl. Task Corfiguration (Fik]
& | DaitazpyerTask

£ Mot T azk a b abionT ask:

& 2 PleTask 3 PleT ask

I 0 Matchies) H 3 DiFFerence(s)]

Compare all Sub-elements Cloze Help |

Y

Fig.3-81: Comparison. Task configuration, tasks as "Direct subelements”

The "DataserverTask" task is only contained in the file storage and can be
accepted into the project.

If the assignment in the columns of the two objects differs, can be used

to select the next difference ( for the previous difference).

If the checkmark appears, it can be used to prepare the acceptance
(merging):

Select the hammer to merge.

Select the cross ﬂ to prevent (undo) merging.

-i._nt' omparison H_::HLIE %
)= S
Left Elements [Proisat] Flight Elemenis (Fila]
| Task Configurstion Task Canfguration
I:@ Diatesatve Tagk
| & mationTaskc MeotionT ask
|& PicTast PlcTask
1
Fig.3-82: Comparison. Application with all subelements with filter option "All ele-

ments” "Different elements” "ldentical elements”

Task objects are compared in tabular form. Here, comparison between the
"PlcTask" and "MotionTask" tasks.

= Merging is not recommended...
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e.'ll'rol Bplorer * L« R Comparison EEE
= = Fro| Compare : ) |
@12 General module falder ' 2 l u £ I (X §A
= Q Application Elersnt PlcTask (Pioject] MotianTask [Pioject]
o () Folder_01 Find3T azk Cyahs ExtemalEvert
ol GYL_Sender Priailty B 2
o MicarGiobal Interval 142010
S setfarGlobal Uri
. Library Manager Intervalllni :
] MatianFrog_FED (FRE) Enshlzd Falie: Tiue:
i N‘I_otianF'mg_FIJ_F' [FRG) Time H2ms
MotionPro [PRG) TirieLrit i s
MotiarFroa [PRG] Sensilivly ]
PleProg (PRG] -
- __: Symbol configuration F.'DU - FlzFrog MationFrog
= (B Task Configuation [ 2 matchtes) | 7 Diferencets) |
o g'ﬂgﬁﬂﬂﬁm; !
Lo g5 PloTask T I
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P e
Fig.3-83: Comparison. Task, here comparison between the "PlcTask" and "Mo-

tionTask” tasks

Comparison: Folder (Differences with Respect to the IndraWorks Folder)

Only the name is displayed. It can be renamed if the folder in the file (right)
has another name.

“ GYL_Sender
- Micy arGlobal

|Jzerv arGlobal
M Librarny Manager
-] MationProg_FBD [PRG]

., Comparison B
= = Proj Compare "
S Generl medule foldss HERMEaN
= E M P o
= [} Application Element Folder 01 [Project] [Folder 07 {File|
feen| ) Falder_O1 Mame Folder_01 Folder_01

| 1 Match(es) " 0 Difference(s) |

Fig.3-84:

Comparison. Folder

If the assignment in the columns of the two objects differs, can be used

to select the next difference ( for the previous difference).

If the checkmark appears, it can be used to prepare the acceptance

(

merging):

Select the hammer to merge.

Select the cross E to prevent (undo) merging.

Comparison: Data Types

The comparison applies to all data types that can be created with the DUT
editor as independent objects.

Among others, the following are supported: structures (STRUCT), arrays
(ARRAY), unions (UNION), enumeration data types (ENUM) and partial
range data types (SUBRANGE).

When data types are compared, the content is displayed as text and can be
modified.
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wm Profect Enplorer

B F_E]__| Fioj_Caormpare
B+ lj General module falder

‘Ainalog 18_Input_Data

% Hnala Data

=] GetBooleanProperty (FLIN]
=] GetCompany [FUMN)

=] GetNumberProperty [FUN)
=] GetTestProperty [FUN)

GetTitle [FUN)
Getersion [FUN]
GatversionFropeity [FLIN]
Library Inlo

# [ Ml
[l Mie2

- "_l:omparison !EE
-An0 Ean
& Dats | Buid propeties
| # AcceptBlock + Accept Single
l-nﬁa%ug;__m;{ﬂmt} ]ma]mgﬁm{?ﬁe}

L owm A | mm =
2 DNALOG DITA: INT (-4095..4095); MALOG DATA: THT (-9999..9980);
3 1/ Sudpange data type =
|

EHD TYFE.
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Fig.3-85: Comparison. Dafa Types

The next/previous difference is selected with 4 or ‘&

ﬁ; Accept Block can be used to accept the coplete highlighted text block.

"Ii .
Accept Single can be used to accept text line by line. In this case, only

the possible result of the merge is displayed first. Clicking the button again
resets the display.

Select the hammer . to merge.

Select the cross ﬂ to prevent (undo) merging.
The next tab shows the build properties.

R componson ——
l n[lumm-::s

[Ghjectz.
False
Ereind implemendation | Falie Falze
Ao gystem call Falze Falze
Ailways link Falze Falze
Compiler definitions Test_ar=TRUE
| 4 Matchies) || 1 Difference(s)|

Cloge | Help |
Vi

Compare all Sub-elements |

Flig.3-86: Comparison: Build properties object 1/object 2, one difference identi-

fied and marked in red

If the assignment in the columns of the two objects differs, can be used

to select the next difference ( for the previous difference).

If the checkmark appears, it can be used to prepare the acceptance
(merging):

Select the hammer to merge.

Select the cross E to prevent (undo) merging.
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Comparison: Global Variable List, Persistent Variables, Network Variables

The comparison applies to all global variable lists @, global variable lists
used as network variables on the sender end @ and persistent variable lists

® that can be added as independent objects of an application (or in the gen-
eral module folder).

== Ml_t!
3 g_g

5 Lagic
=3 Foider 0
& g «———— )
@ Mic/arGlobal ::7 (1)
Lz arGiohal
Libray Managel
;Eﬂ MotionProg_FED [PRG]
E] PicProg [PRG]
488 Task Configuration
Tr' Persistentvars t————o {3}

Fig.3-87: Comparison. Possible global variable lists

When data types are compared, the content is displayed as text and can be
modified.

w Project Explorer

5 =1 Pioj Compare
= D Geresal module foldei
= Bl M1
& 8l toge
= Application
— 5 Folder M
@ GVL_Serder
@ Micvariohal
Used/aiZiobal
Library Manzger

2] MotiorFrag FED [FRG)
8] Moborfrog FUP [PRG]

(5] MotiorPro [PRE]
_;ﬂ MobioriProg (PRG)
(5] FicFiog [FRG)
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£2# MotionT ask
% PlcTask
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™ Comparison
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otSorr ()

iglobwar: THT:
-
|#[ ]
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Hl addition(s)”ﬂ deletion(s)”ﬂ change(s)|

[+

strglobvar: STRING: strglobvar: STRING:
EHD VAR

END VAR
4] '

|C0mpare stakistics:

Close |

Fig.3-88: Comparison. Global variable lists

t.

The next/previous difference is selected with ¥ or

? Accept Block can be used to accept the coplete highlighted text block.
v Accept Single can be used to accept text line by line. In this case, only

the possible result of the merge is displayed first. Clicking the button again
resets the display.

Select the hammer to merge.

Select the cross E to prevent (undo) merging.
The next tab shows the build properties.




